1. Visiting from the US? Why not try DIYnot.US instead? Click here to continue to DIYnot.US.
    Dismiss Notice

'T' reg Punto - Where do I look first!?!

Discussion in 'Car Repairs / Maintenance' started by bodminman, 5 Feb 2008.

  1. bodminman

    bodminman

    Joined:
    13 Feb 2006
    Messages:
    93
    Thanks Received:
    0
    Location:
    Suffolk
    Country:
    United Kingdom
    Hello everyone,
    My daughter has had a 'T' reg Punto now for a few years and hasn't had any trouble with it at all until late last week.

    Basically the heater doesn't appear to be working. Her commute to college is approx 7 miles and she said that normally by approx the 2 mile mark the car is starting to warm up nicely, but now it isn't. The fan just continues to blow cold/cool air all the to and from college. I took it for a 10 mile drive last night and can confirm that this is the case.

    I'm no mechanic etc but tend to be happy looking for things once given a wee bit of guidence so your help will be greatly appreciated.

    Regards
     
  2. Sponsored Links
  3. johnwr

    johnwr

    Joined:
    11 Sep 2005
    Messages:
    215
    Thanks Received:
    0
    Location:
    Yorkshire
    Country:
    United Kingdom
    Have you checked the water level, if thats OK check the temperature of the top hose, if its cold, then change the thermostat, if it's hot bleed the heater.
     
  4. alfiembra

    alfiembra

    Joined:
    5 Feb 2008
    Messages:
    72
    Thanks Received:
    1
    Location:
    Aberdeenshire
    Country:
    United Kingdom
    Could be several things had a similar problem with an old beamer turned out to be the water pump. Is the car getting up to temperature ok may be thermostat stuck open.

    Alan
     
  5. bodminman

    bodminman

    Joined:
    13 Feb 2006
    Messages:
    93
    Thanks Received:
    0
    Location:
    Suffolk
    Country:
    United Kingdom
    Hi guys,

    thanks for your help. Here is what I've done so far:

    Drained the radiator and blasted a jetwash the wrong way round and blasted a load of rubbish out.
    I then refilled the system up and and now the heating is working a treat.

    However, (there's always one isn't there!?!) the car, if standing will start to over heat. Any clues?

    Thanks
     
  6. Belle427

    Belle427

    Joined:
    16 Jan 2006
    Messages:
    2,930
    Thanks Received:
    280
    Location:
    Newport, S Wales.
    Country:
    United Kingdom
    air lock
     
  7. Sponsored Links
  8. Stivino

    Stivino

    Joined:
    11 Oct 2006
    Messages:
    2,728
    Thanks Received:
    230
    Location:
    Midlothian
    Country:
    United Kingdom
    Is the radiator fan cutting in?
     
  9. libby lou lou

    libby lou lou

    Joined:
    16 Oct 2006
    Messages:
    3,756
    Thanks Received:
    43
    Location:
    Lancashire
    Country:
    United Kingdom
    Try blasting it the other way, apart from what stavino said.

    careful with that jetwash
     
  10. BOROBOY2

    BOROBOY2

    Joined:
    16 Sep 2005
    Messages:
    55
    Thanks Received:
    0
    Location:
    Middlesbrough
    Country:
    United Kingdom
    If not airlock. May be blocked thermostat.
     
  11. luke_vibert_uk

    luke_vibert_uk

    Joined:
    14 Nov 2006
    Messages:
    119
    Thanks Received:
    3
    Country:
    United Kingdom
    If it is an airlock, when re-filling make sure you locate and open all anti airlock valves along the pipe runs...small little screw in round plugs moulded into hoses with a slot in the top.

    Fill to level of first then close, fill to second then close and carry on until full....assuming the Punto has them...
     
  12. tryingnottobeafool

    tryingnottobeafool

    Joined:
    1 Oct 2007
    Messages:
    154
    Thanks Received:
    0
    Location:
    Glasgow
    Country:
    United Kingdom
    make sure all wires are connected up

    temperature sending unit is sensitive and you may have damaged it so fan doesnt know to cut in
     
Sponsored Links
Loading...

Share This Page