Upstairs radiators won't fill up after draining

The pump has isolating valves either side, they are the ones that look like old style taps with the circular turn knob - no idea if they will actually close properly to stop leaking when I get the pump off.
Sponsored Links
Shut off the supply to the header tank just as a safeguard. Remove the power from the pump, close both valves, put a tray and loads of old towels etc around to catch any leakage. Undo one of the pump connectors - slowly. You will soon know if they have closed fully or not!

If not then do the connector up again - it may still leak a bit - and drain down as you have before until the water level is below the pump, then you can remove it without any worry. Always worth having an extra pair of hands around if you can - just in case you need some assistance.
So pretty much the same principle as isolating a radiator then?

Drain down might be the best option as the pump is under the floorboards so any leaking is going right through the ceiling!!

Once I've got the pump off, then what?

What should I look for in terms of worn parts, signs it needs replacing, signs it just needs cleaning etc?
Hi all,

So I decided to have one more go at this damn thing and I thought I'd managed to fix it but it's still not working as it should.

I've bled again, tied up ballcock and drained the dropfeed rads. Filled via the tank and bled each rad in turn starting downstairs and working my way upstairs including the pump.

Turned it on with all valves fully open and I got 3x hot rads upstairs and nothing downstairs. The rads downstairs had hot flow pipes and started to warm up a little so I thought it was a balancing issue.

But I've tried turning the rads off upstairs to force the flow through the rads and I can't get them hot.

I've even had the pump off this time and made sure it was rotating and it is/was when I'd got it off.

The problem is still that the temperature at the boiler is too high preventing it from firing and even with the pump running and the boiler not fired up the temperature isn't really reducing that much.

The system is full of inhibitor now so I really don't want to go through another draining process so has anyone any ideas now?

The only thing that hasn't been changed is the pump but with it spinning I thought that meant it was working so I have left that alone.

There's no air in the system, I've bled the rads again and there is no air in the system and there's no air in the pump so I don't see how this can still be an air lock problem.

Before I go out and spend £100+ on a new pump is there anything else I can try?
Sponsored Links
I've not read this whole thread but try Tracking along as much of the pipe, as you can, with a magnet, if it sticks to the pipe there is magnetite in it which will reduce or stop circulation.
It's most often an empty F&E tank or a blocked cold feed. Have you tried that first?

DIYnot Local

Staff member

If you need to find a tradesperson to get your job done, please try our local search below, or if you are doing it yourself you can find suppliers local to you.

Select the supplier or trade you require, enter your location to begin your search.

Are you a trade or supplier? You can create your listing free at DIYnot Local