Vaillant Ecotec Plus 637 won't heat water in Unistor unvented cylinder

19 Nov 2023
Reaction score
United Kingdom
I have a Vaillant Ecotec 637plus system boiler feeding a Unistor unvented cylinder for HW and radiators in just one heating zone controlled by a VRC470F, weather compensation sensor, VR61 control box and VR10 cylinder thermostat. All installed about seven years ago.

Two or three months ago it stopped heating the cylinder. The boiler tries to provide hot water but an hour glass symbol shows because the motorized valve is closed and the pipe downstream of it stays cold with no HW going into the tank. I assumed the Honeywell V4043H1056 motorized valve itself had failed again. However we have economy 7 so have been using that to power the immersion overnight until I could get round to fitting a new head unit.

In the meantime I had trouble recommissioning the CH after summer because the installer settings for HEATING 1 thermostat and heat curve somehow seemed to have been reset to their defaults when I checked on the VRC470F. CH worked again once settings restored to room thermostat and 2.4

Last week, before buying a new head unit for the valve, I thought I’d better check if the LP/ZP terminal in the VR61 was sending current to it and I found that actually it wasn’t. So I fitted a new VR61 instead but still no current to the LP/ZP live terminal.

With CH off, I then manually opened the valve and hooked it back to stay open. The boiler then stopped hour glassing and fired up with the ‘Cylinder temp current’ rising to 61 at which point it turned off so I don't think there's anything wrong with the VR10 thermostat and I haven't changed it to use the new one that came with the VR61.

Part way through the heating process I unhooked the lever on the valve and it immediately returned to the closed position and the boiler shut down until I manually re-opened it again

Because of my experience with the CH installer settings having been re-set to default I next checked those for HW and found “LP/ZP rely con” was set to ‘No connect’ which according to the controller installer guide is the factory default setting but seemed to be for where no VR61 is fitted

Looking at other settings, Charge Pump is Off but Circulation Pump is On so I changed the LP/ZP Relay setting from ‘No connect’ to ‘Circulation’. However that did not resolve the issue. After using some of the water in the cylinder it failed to recharge and the controller showed a current temperature of 28 degrees and the boiler with the hourglass and tap symbol trying to charge but pipework cold downstream of the valve. Still no current on the LP/ZP terminal.

The installer system configuration settings for DHW as shown on the VRC470F are now as follows.
Cylinder: Active
Cylinder temp. target: 61
Cylinder temp. current: 28
Cylinder charge pump: Off
Circulation pump: On
Anti Legionella day:Off
Anti Legionella time:4
Cylinder Boost offset: 25k
Load Pump: 5min
Paral Cyl charge: Off
LP/ZP relay con: no connect.

Can someone on here advise if those are correct for my setup?

If so what should I try next?

Perhaps there’s a problem with the receiver on the boiler? In which case the best solution may be just to upgrade the whole control system. As it is the boiler forgets the current datetime if power is turned off for more than a few seconds so its capacitor is clearly on the way out and the VRC470F is increasingly flakey too. The loss of the installer thermostat and heat curve settings for the CH this year being just the latest problem.

Ultimately I want to add a second zone for underfloor heating in an extension and I’m not convinced a wireless controller works well given the location of the boiler one floor above the controller so was thinking of going to a system based round the SensoComfort VRC 720 at some point anyway.

Short term though i’d like to stop having to use electricity for HW ASAP. Can anyone help?
Sponsored Links

I noticed changing the LP/ZP Relay setting from ‘No connect’ to ‘Circulation’ seemd to have reverted itself so changed it again and a few hours later Cylinder temp. current is 61 without the immersion on. :)

So the problem seems to have been caused by corrupted system configuration settings just like it was for the CH previously.

So all good short term but longer term I think I need to update the control system to the new sensocomfort 720 and probs the wired version sooner rather than later. It's a bit tedious having to keep reinstating installer settings to keep the system running properly so any advice on that welcome.

DIYnot Local

Staff member

If you need to find a tradesperson to get your job done, please try our local search below, or if you are doing it yourself you can find suppliers local to you.

Select the supplier or trade you require, enter your location to begin your search.

Are you a trade or supplier? You can create your listing free at DIYnot Local

Sponsored Links