Vaillant ecoTEC Plus appears dead

Joined
2 Dec 2013
Messages
3,962
Reaction score
510
Country
United Kingdom
A neighbour has a Vaillant ecoTEC plus combi.
It appears completely dead, i.e. the LCD display shows nothing at all.
I believe power is present at its FCU as the neon is on.

I’m not familiar with this boiler. Does it normally show something on the display if power is present but the boiler is not running?

An engineer attended last week because there was a drip from the bottom of the case; a split condensate hose was replaced. It has worked OK for a few days until now. (I wonder if drips of condensate have got into the electrics, and have taken a while to kill it?)

No doubt they will get someone out again but if anyone has any ideas about obvious things to check now, that could be useful.
 
Joined
8 May 2017
Messages
6,649
Reaction score
1,415
Country
United Kingdom
Check the voltages present at the boilers supply terminals Line to neutral. If 230/240 volts ,the supply is ok and issue is within the boiler ,probably the PCB.
 
Sponsored Links

CBW

Joined
26 Sep 2019
Messages
11,648
Reaction score
3,256
Location
North
Country
United Kingdom
Does it still work? I’ve had it once where the heating and hot water work, just front display needed replacing.
 
Joined
2 Dec 2013
Messages
3,962
Reaction score
510
Country
United Kingdom
Check the voltages present at the boilers supply terminals Line to neutral. If 230/240 volts ,the supply is ok and issue is within the boiler ,probably the PCB.

Yes, I’ll do that if I go back.

Does it still work? I’ve had it once where the heating and hot water work, just front display needed replacing.

Ha! No, definitely not working.
 
  • Thanks
Reactions: CBW
Sponsored Links
Top