1. Visiting from the US? Why not try DIYnot.US instead? Click here to continue to DIYnot.US.
    Dismiss Notice

Valiant Ecotec Plus 837 Central heating stuck on ignoring thermostat

Discussion in 'Plumbing and Central Heating' started by Essexdrew, 1 Nov 2019.

  1. Essexdrew

    Essexdrew

    Joined:
    1 Nov 2019
    Messages:
    4
    Thanks Received:
    1
    Country:
    United Kingdom
    Hi all, can you help ?
    Have a Valiant Ecotec Plus 837, the central heating runs all the time ignoring the roomstat.
    Hot water is fine
    No error codes
    When i look at the control panel the RAD picture is visible.
    When set to on via timer function the heating switches on and off but ignores the roomstat, if the boiler is set to comfort mode CHS runds all the time depending on what I set the flow temp at.
    I have seen a similar thread to this on a Valiant where the fix was to chnage the PCB anyone have any thoughts ?
    Cheers
    Have just checked in installer mode and with heating on and stat not calling for heat it is showing 0 ( open ) Have now set stat to call for heat and it still shows 0 (open) could this be a stat problem ?
     
    Last edited: 1 Nov 2019
  2. Sponsored Links
  3. stem

    stem

    Joined:
    20 Jul 2005
    Messages:
    5,619
    Thanks Received:
    1,149
    Location:
    Nottinghamshire
    Country:
    United Kingdom
    What make / model of room stat do you have?
     
  4. Essexdrew

    Essexdrew

    Joined:
    1 Nov 2019
    Messages:
    4
    Thanks Received:
    1
    Country:
    United Kingdom
    Its a SALUS, just had the front off the boiler and unplugged the two wires from the stat putr a meter across them and can see a full short when i make the stat call for heat and then open circuit when i stop it calling. Looks like its pointing to the PCB ?

    The diag mode on the boiler reports as open when the stat is calling for heat and when it isnt.
     
  5. stem

    stem

    Joined:
    20 Jul 2005
    Messages:
    5,619
    Thanks Received:
    1,149
    Location:
    Nottinghamshire
    Country:
    United Kingdom
    That's the make, but not the model. There are several versions of the Salus, so I was hoping you would be a bit more specific.

    Anyway, usually Salus thermostats have terminals marked 'Com' and 'NO' if you want to test it and are are able to do so safely, turn off the power, open up the room thermostat and have a look. If that's what you have, remove the wire from the 'NO' terminal and isolate it safely. Then turn the power back on. If the radiator symbol doesn't come on now, then the thermostat is the cause of your problem. If the heating still does come on the fault is elsewhere.
     
    • Like Like x 1
  6. Sponsored Links
  7. Essexdrew

    Essexdrew

    Joined:
    1 Nov 2019
    Messages:
    4
    Thanks Received:
    1
    Country:
    United Kingdom
    Hi there, its a RT300.
     
  8. stem

    stem

    Joined:
    20 Jul 2005
    Messages:
    5,619
    Thanks Received:
    1,149
    Location:
    Nottinghamshire
    Country:
    United Kingdom
    OK it's L and SL then:

    If you want to test it and are are able to do so safely, turn off the power, open up the room thermostat, remove the wire from the 'SL' terminal and isolate it safely. Then turn the power back on. If the radiator symbol doesn't come on now, then the thermostat is the cause of your problem. If the heating still does come on the fault is elsewhere.
     
    • Like Like x 1
  9. Essexdrew

    Essexdrew

    Joined:
    1 Nov 2019
    Messages:
    4
    Thanks Received:
    1
    Country:
    United Kingdom
    Hi Stem, just found a post you posted a couple of years ago about how to wire up the Salus receiver to a Vaillant ecotec plus. I followed your guide and within minutes it was all working !!
    It turns out that the boiler had never actually been wired up correctly to the thermostat in teh first place, now have fully working CHS that is obeying commands from the room stat.

    Thanks for talking the trouble to reply:sneaky:
     
    • Thanks Thanks x 1
  10. stem

    stem

    Joined:
    20 Jul 2005
    Messages:
    5,619
    Thanks Received:
    1,149
    Location:
    Nottinghamshire
    Country:
    United Kingdom
    Good, glad to hear that you resolved it.
     
Sponsored Links
Loading...

Share This Page