Valliant Call for Heat issue

14 Jan 2013
Reaction score
United Kingdom
I have a Valliant ecotech pro 24 combi boiler with a Salus RT500RF wireless thermostat.

I have the thermostat set to 17 degrees on all 5 'on' time settings (no 'off' time setting) and then I just use the temp control to up the temp if and when I need to. This has worked flawlessly for the past 2 years.

Recently I am having problems whereby if I increase the temp manually the boiler doesnt seem to get a heat request, or it will get the request and just come on for 5mins max before switching off again. It does still seem to work with keeping the temp at the 17 degrees as this is what the thermostat shows when I get home from work on various shifts.

Today I turned the thermostat all the way up to 35 degrees and then the boiler heating control all the way to max, everything fired up and started to heat again but after 5 mins tops the green heat call light on the receiver goes off and the heating stops.

I have put brand new durcell power plus batteries in the thermostat as well as hitting the reset button and reprogramming but still doesn't help.

While writing this I went back to the boiler to check if it was calling for heat (boiler heating temp max and thermostat max still) and it wasnt. When I press the 'i' butting it is showing S.7

Any help would be appreciated
Sponsored Links

DIYnot Local

Staff member

If you need to find a tradesperson to get your job done, please try our local search below, or if you are doing it yourself you can find suppliers local to you.

Select the supplier or trade you require, enter your location to begin your search.

Are you a trade or supplier? You can create your listing free at DIYnot Local