Valliant Ecotec plus 837

31 Jan 2009
Reaction score
United Kingdom

I have an issue with my valliant pluse 837...

I have warm and hot heating - when the taps are turned on ...but when trying to turn on the central heating via the remote control which we have the heating does not coming as per normal...

the IR controller we have is

Siemens RDJ10RF thermostat

the amber light flashes on the reciever for a few seconds but nothing happens...

and then when pressing the 'I' on the boiler the following is displayed.

T5 140

any suggestions and help would be most welcome...

Thanks alot
Sponsored Links
Its not very clear to me what your symptoms really are.

It may well be that the diverter valve is sticking.

Could you try to clarify how the hot water works and seperately how the heating is working?


thanks for quick reply..

I have sorted the problem out.

the thermo stat controller - and reciever were not talking to each other so any attempt made to put the heating on using the thermostat adjuster thing failed...

so pairing the two device together has worked...fingers crossed thts'

Thanks anyway I startd to worry for abit there

the issue has come back again..where a the command from the RDJ10RF reciever is not being sent to the reciever that is attached to this boiler hence when a command for heating is made the boiler does not come on to provide central heating.....

I have once paired the RF thermostat together with reciever but cannot do it this time round - have tried many times again....

Is there any way of manually turning the central heating on without using that heap of junk of remote...........

Thanks Alot.
Sponsored Links
s31 is status code I am getting.

'central heating thermostat knob turned off or no heat demand by the ebus control unit.

on the RF transmittor there is heat demand -
but for some reAson not pairing with the reciever ...

I hope its just the the batteries in the remote/transmittor.

but is there anyway around this in the mean to get the heating back up bypassing the rf controls!!!!

obv without having to re-jig anywires

thanks alot.
PS its freezzzzzzzzzzzin :confused:
The first thing to always check or do in this situation is to change the battery in the sender unit!

If you havent done that yet then you are wasting your time and ours!

Terminals 3 + 4 need to be linked to simulate a physical timeclock and room stat.

However, when you have an Ebus control connected, I am not sure if both control systems will operate in parallel or if either takes precedence.

Ebus won't be being used as it is a Siemen programmer stat.

I hope you are using proper alkaline batteries and not re-chargables, as re-chargeables won't operate RF units properly.

When using an ebus controller the link between 3 & 4 remains in place.

DIYnot Local

Staff member

If you need to find a tradesperson to get your job done, please try our local search below, or if you are doing it yourself you can find suppliers local to you.

Select the supplier or trade you require, enter your location to begin your search.

Are you a trade or supplier? You can create your listing free at DIYnot Local