1. Visiting from the US? Why not try DIYnot.US instead? Click here to continue to DIYnot.US.
    Dismiss Notice

Vauxhall Combo Isuzu engine problem

Discussion in 'Car Repairs / Maintenance' started by Nige F, 31 Jul 2018.

  1. Nige F

    Joined:
    28 Jun 2005
    Messages:
    19,467
    Thanks Received:
    1,382
    Country:
    United Kingdom
    Guys, my old (2001 ) combo with the "no electronics" diesel engine has a problem with the Glow Plugs heater (relay clicking and warning light illuminating ) while driving for aprox. 1 second at random intervals. I found the relay and got a new one (£8 ) but despite searching the www I can't find 'owt else to do with it - so I can't even jury rig a supply (from a fuse ? ) and a push button to operate the glows manually. Any ideas ? Thanks.
     
  2. Burnerman

    Joined:
    7 Feb 2008
    Messages:
    18,580
    Thanks Received:
    3,601
    Location:
    Northumberland
    Country:
    United Kingdom
    I guess your van doesn't have a DPF Nige, but it will have an EGR system. If its getting blocked you can get symptoms such as yours.
    John :)
     
  3. Nige F

    Joined:
    28 Jun 2005
    Messages:
    19,467
    Thanks Received:
    1,382
    Country:
    United Kingdom
    It does have an EGR - it's a mechanical one with a valve operated by a vacuum pipe. Would one of the aerosol cleaners - squirted in the inlet manifold - work or should I take the valve out ? I'd never have guessed it was about the EGR valve . Thanks.
     
    Last edited: 24 Aug 2018
  4. Motman

    Joined:
    27 Feb 2017
    Messages:
    1,601
    Thanks Received:
    210
    Location:
    Essexshire
    Country:
    United Kingdom
    I can vaguely remember doing something similar on a friends 2001 combo years ago. IIRC, the relay was behind the passenger kick panel and I just disconnected the relay switch wire and operated the relay by fitting a press button with a switched live feed on the steering column shroud.
     
    • Thanks Thanks x 1
  5. Nige F

    Joined:
    28 Jun 2005
    Messages:
    19,467
    Thanks Received:
    1,382
    Country:
    United Kingdom
    Update - I got a blanking plate for the valve/air box. It still did the flashing. I located a electric/vacuum valve so disconnected the power - sorted (bodged :whistle: )
     
  6. Burnerman

    Joined:
    7 Feb 2008
    Messages:
    18,580
    Thanks Received:
    3,601
    Location:
    Northumberland
    Country:
    United Kingdom
    Nice one Nige (y)
    Did you notice any power hesitation before your repair?
    John :)
     
  7. Nige F

    Joined:
    28 Jun 2005
    Messages:
    19,467
    Thanks Received:
    1,382
    Country:
    United Kingdom
    Latest update - van is in for welding and new front wheel bearing ( MOT ) But the glow plugs and relay are still clicking on/off while it's warming up - on tickover it doesn't like the extra hot air and " misses" a bit - fine when warm . So it's the Final Solution time - I have some heavy duty 2 pole Toggle switches and I'll wire one into the actuating wires going to the relay. ON for a cold start then OFF for the rest of the day. And maybe a security thing cuz it won't start if nicked. Not that anyone would bother LOL;)
     
Loading...

Share This Page