Baxi Duo Tec 40 HE A Fluctuating Hot Water Temperature

Sponsored Links
Sponsored Links
Did you get to the bottom of the fault on your boiler?
I had a boiler installed in March 2020 and I have a very similar problem, but when I run my tap, the water is Luke warm, even at max temp. Upon turning two taps on, water goes to the required temperature (or somewhere close without a thermometer). The water pressure is running at between 1 and 2 bar pressure.

The gas fitter said I need more pressure/flow, but it has been running fine for around 6 months before this problem. I have not noticed any drop in mains pressure and water flow per minute is approximately 7 litres per minute.

Any help would be appreciated.

Thank you for that Alec.

I’ve been doing a little research, and that’s the part that seems to be the issue on a couple of other threads.
I wouldn’t know how to check the flow sensor, but at least I can go back to the fitter and ask him to check that.

I’ve just been up to try it again and it’s very weird. If I put the shower on hot and the hot bath tap on, the shower is hot but the bath tap is as cold as the cold tap (the shower is closer to the boiler). If I turn the shower off and put the basin hot tap on with the hot bath tap, the bath tap is hot and the basin tap is cold (the bath is closer to the boiler than the basin).
It is totally baffling.
Another with the same issue!!

I found this thread whilst looking for a solution for the same issue.

Baxi Platinum Combi HE 40, installed about 10 years ago and apart from a couple of thing over the years (expansion tank, over pressure valve leak) it's worked perfectly.

Yesterday, plumbers (Corgi Home cover - local plumbing firm) were here to change a leaking rad valve, drained down the system - replaced valve, bled rads & pressurised system, all good.

Today, shower temp fluctuating (it's never done this before), so I read this thread and started testing:- Turn on HW tap near boiler, and get same issue as original poster e.g. DHW temp climbs to 97Deg on display then burner shuts off, temp reduces then at about 40Deg the burner fires up, 97, 40, 97, and so on.....

Clearly the boiler is no longer modulating like it used to.

I tried turning off the mains water to the boiler whilst the HW was running to see if that temporarily fixes the issue (like the original poster) but it didn't. Still not modulating.

So, does anyone have any suggestions for further tests to see where the fault could be before I contact Corgi Homecover? I don't want them to start replacing things at random and run into the same problem as the OP.


Update:- solved by replacing the flat plate heat exchanger.
Last edited:
3 years and counting
Last edited:

DIYnot Local

Staff member

If you need to find a tradesperson to get your job done, please try our local search below, or if you are doing it yourself you can find suppliers local to you.

Select the supplier or trade you require, enter your location to begin your search.

Are you a trade or supplier? You can create your listing free at DIYnot Local

Sponsored Links