Galaxy Flex 100+ Woes

2 Jun 2022
Reaction score
United Kingdom
Hi All,
I have a Galaxy Flex 100+ control panel and MK7 Keypad. I purchased the panel with the GSM module, ethernet module and separately purchased a SELFMON card.
I connected mains power, battery, and RS 485 connections for the SELFMON and the MK7 keypad (no zones connected) and powered on. The keypad displays the classic row of stars and emits a continuous tone. Having read quite a few threads on here about this situation, I verified connectivity from the panel to the keypad and all were OK. I checked the voltage across the power rail on the RS485 connector - 13.8V, checked it it at the keypad - 13.8V. I then checked the voltage across the A & B connections at the panel and the keypad - both around 3.1V (meter set to volts DC) and not really fluctuating.
I tested the keypad by powering on whilst pressing the enter key. The LCD worked fine, as did all the keys, so at least that part of the keypad is proven working. I have tried every address from 0 to 15 on the MK7 to no avail. After about 30 seconds of the power on, the red diagnostic LED in the top middle of the panel goes from off (no flashing) to solid red. I presume this indicates an error, but I cannot for the life of me find any information on the diagnostic LED and what it's behaviour is.
I also checked the voltage between 0V and 12V on each of the zone connectors, they all showed 13.8v.

I repeated all these checks with the SELFMON and the ethernet modules disconnected. The result was the same as before.
The green light on the top right of the GSM/GPRS module flashes about once per second (there is no SIM in it yet).

It looks to me like the panel is faulty, but is there anything else I should try before contacting the seller for a replacement?

Many thanks for your help.
Sponsored Links
Hi, the LED on the Flex will give a very quick flash at power on. It will then illuminate constantly after about 40 seconds, then when the bus is configured after another 50 seconds, it will flash and give a 0.1/0.9-second quick flash. At this point the keypad communication starts. Your panel seems to be getting to the point of bus configuration, then stopping. This shouldn't happen, but I have seen an error like this if +12V is wired into a zone by mistake.

If you disconnect the wired zones, keypad and vmod then power on to check to see what the LED does that will rule out any wiring type issue and narrow down to the main PCB. It does take about 1.5 mins to boot on the Flex panels, as the operating system takes time to come up, so allow for that when doing the test.

If you've bought the panel from myself, be assured that I test the control panel and peripherals prior to shipping to avoid any issues. If there does turn out to be a problem, I'll arrange a swap-out quickly from stock and I'll then take care of any return with Honeywell as this can take weeks.

If bought from me, please get in touch via e-mail and send a pic of your wiring. I'll support you 100% to sort out any issue.
Last edited:
I've updated the timings above, as the initial time until the LED illuminates can be around 40 seconds and not 10.
Sponsored Links
Hi Everyone,
Just a quick update to say the problem above has been sorted, by excellent email support from galaxy_guy, from whom I purchased the panel.
Thanks galaxy_guy

DIYnot Local

Staff member

If you need to find a tradesperson to get your job done, please try our local search below, or if you are doing it yourself you can find suppliers local to you.

Select the supplier or trade you require, enter your location to begin your search.

Are you a trade or supplier? You can create your listing free at DIYnot Local