Hotpoint Ultima Extra WD72

Joined
17 May 2008
Messages
4
Reaction score
0
Location
Kent
Country
United Kingdom
Hi,

The above machine no longer seems to have heat on the drying cycle.

Is this likely to be the element & if so are they easy to replace, & best place to buy from?

All help much apprecited.


Simon
 
Sponsored Links
Joined
3 Jan 2003
Messages
23,197
Reaction score
30
Location
Sussex
Country
United Kingdom
no it will be a stat

a stat will go if the fan doesnt work or heater is blocked
 
Joined
17 May 2008
Messages
4
Reaction score
0
Location
Kent
Country
United Kingdom
Cheers Breezer,

Is it possible to reset them/it or do you need new ones?

Is this easy to do?

Thanks again
 
Joined
29 Apr 2008
Messages
587
Reaction score
68
Country
Croatia
If you take the lid off the machine you will see the thermostat / TOC devices, small cylindrical or cube shaped components with 2 spade terminals, mounted on the heater housing on top of the drum. An easy way to check which one has failed is to join the 2 wires together from one, check if the machine is now heating, if not, repeat this check for the next. Obviously you make sure the machine is unplugged before touching any wires. Also check if the fan is going.
 
Sponsored Links
Joined
18 May 2008
Messages
1,256
Reaction score
196
Location
Cornwall
Country
United Kingdom
Just done one of these the wiring loom was so tight that the wires to the elements had snapped off of the spade connectors. I had to extend and re route the wires.
 
Sponsored Links
Top