Immersion Heater


29 Jun 2004
Reaction score
United Kingdom
I cannot remove my faulty immersion heater, I have tried box and open spanners, hitting them sharply with a hammer. Also used a blow lamp to heat the boss of the immersion heater all to no avail. I believe the problem is due to boss white being used to fit the heater.

Is there any none solder gizmo that I can use if I cut the immersion heater out of the tank which would allow me to fit new immersion.

The tank is coated with fibreglass.
Sponsored Links
have you tried (very carefully) a knife to break the seal?

tried tightening it first, again to break the seal

but be VERY careful
Had the same problem many years ago. I used an 18" stilson wrench on it.

Bent the tank and ended up replacing it. Take care with it. :)
As others have said - BE CAREFUL.
With the cylinder FULL but with the supply to it OFF, use a box spanner and hit the tommy bar sharply with a hammer first to TIGHTEN the joint (clockwise), then try loosening it again.

Luck of the draw applies - if you're lucky, it'll come undone. Otherwise you'll buckle / shear the tank top and will need to replace it.

Once it's buckled, there's no practical way to repair it.
Sponsored Links
I had my immersion box spanner drilled out to 20mm and used a 1m long 18mm steel bar instead of the one provided with the spanner. There wasn't an immersion heater I couldn't shift......................ahhhh those were the days.
Thanks for all the advice, I am resolved to buying a new cylinder and then venting my rage on the old cylinder with a sledge hammmer.

DIYnot Local

Staff member

If you need to find a tradesperson to get your job done, please try our local search below, or if you are doing it yourself you can find suppliers local to you.

Select the supplier or trade you require, enter your location to begin your search.

Are you a trade or supplier? You can create your listing free at DIYnot Local