Just another Nest wiring problem?

Joined
8 Aug 2017
Messages
4
Reaction score
0
Country
United Kingdom
Hi all,
I've recently purchased a Nest v3 thermostat and had a go at installing it.... It works!....but I have a smallish problem I'm hoping you guys can help with.

Ok, so when I choose to either boost the hot water, or the hot water thermostat kicks in, the boiler fires up, the pump comes on, the actuator valve makes a noise and I get warmish water! And hot radiators :(

Now if I press the manual button on the heat link, I get hot water and hot radiators.

  • The actuator is a Danfoss HSA3
  • I have a Y Plan heating setup
I've included a picture of the heat link wiring, does this look correct?

Heat Link.PNG


Should I be looking at the HSA3? Typically, I didn't get this issue on the old timer and thermostat (the old timer is still in place btw, all these wires and the heat link are next to the hot water tank)

Any help/advice would be appreciated
 
Sponsored Links
Joined
8 Apr 2008
Messages
10,701
Reaction score
2,700
Location
Essex
Country
United Kingdom
You need to post up the complete wiring diagram of what you have, its impossible to tell whats wrong with the snippet you have posted, at a complete guess you have probably not got the "hot water off" wires correctly connected.
 
Joined
8 Aug 2017
Messages
4
Reaction score
0
Country
United Kingdom
Here you go @picasso I've done a complete wiring diagram.

I agree @flameport I'm just not sure how to re-wire it. I do understand that if the timer was on some sort of schedule than that would throw a spanner in the works with the nest, so on the timer HW and CH are manually set to ON

I would also like to remove the frost thermostat, the boiler was in the garage, but we had it converted a few years back, so the boiler is now in a utility room and the frost stat isn't really needed.
 

Attachments

  • Heating Wiring Diagram.pdf
    181.9 KB · Views: 156
Sponsored Links
Joined
8 Apr 2008
Messages
10,701
Reaction score
2,700
Location
Essex
Country
United Kingdom
Can you number the cylinder stat connections or mark as com , nc, no .
 
Joined
8 Aug 2017
Messages
4
Reaction score
0
Country
United Kingdom
Sure, here you go @picasso

I've been checking over the weekend, the lever on the valve had been set to manual, whilst like this, the H/W will come on and also heat the radiators and if I turn the room thermostat up, it will turn the pump on and the boiler.

But if I move the lever to auto, the H/W will come on with the schedule set on the nest app, the H/W boost will work and you can hear the valve motor work, but if I turn the thermostat up to heat the radiators.... nothing. the pump wont kick in at all and the boiler wont fire, I've checked the voltage on terminal block 7 and i get nothing.
 

Attachments

  • Heating Wiring Diagram.pdf
    47.4 KB · Views: 146
Joined
8 Apr 2008
Messages
10,701
Reaction score
2,700
Location
Essex
Country
United Kingdom
Wiring looks ok so new actuator head needed I reckon, but your in front on the boiler so I can't guarantee 100 per cent its gonna fix it.
 
Joined
8 Aug 2017
Messages
4
Reaction score
0
Country
United Kingdom
ok thanks @picasso, right new actuator has arrived, just fitted it and it works! Thanks for your help, now just need to tidy the wiring up and remove the old timer.
 
Sponsored Links
Top