1. Visiting from the US? Why not try DIYnot.US instead? Click here to continue to DIYnot.US.
    Dismiss Notice

Makita Radio not working

Discussion in 'Tools and Materials' started by Jupiter01, 22 Aug 2020.

  1. Jupiter01

    Jupiter01

    Joined:
    30 Mar 2015
    Messages:
    2,607
    Thanks Received:
    28
    Country:
    United Kingdom
    9E2F15AF-E5D2-4F08-AC42-5DC8E28E318E.jpeg
    I’ve got one of these and suddenly the radio isn’t picking up any stations. Tried AM and FM.

    I just get lots of interference. The Bluetooth function still works.

    I am using this in my own house and spots where I know I previously had good reception.

    I’d appreciate any advice you can provide. Thanks in advance.
     
  2. Sponsored Links
  3. blup

    blup

    Joined:
    5 Nov 2007
    Messages:
    1,137
    Thanks Received:
    171
    Country:
    United Kingdom
    Is it within Makita's three year warranty?

    Blup
     
    • Like Like x 1
  4. Jupiter01

    Jupiter01

    Joined:
    30 Mar 2015
    Messages:
    2,607
    Thanks Received:
    28
    Country:
    United Kingdom
    Unfortunately not. I purchased it second hand.
     
  5. mattylad

    mattylad

    Joined:
    27 Apr 2008
    Messages:
    7,377
    Thanks Received:
    489
    Country:
    United Kingdom
    Maybe the antenna has a broken wire, have a look inside and see if the wire to it has become detached.
     
    • Like Like x 1
  6. Jupiter01

    Jupiter01

    Joined:
    30 Mar 2015
    Messages:
    2,607
    Thanks Received:
    28
    Country:
    United Kingdom
    Could it be the antenna itself that needs changing? Would that cause the issue I am describing?

    I will check the wire too. Thanks for your help.
     
  7. Harry Bloomfield

    Harry Bloomfield

    Joined:
    30 Dec 2018
    Messages:
    3,477
    Thanks Received:
    464
    Country:
    United Kingdom
    Unlikely, AM and FM use two different antennas, so unless both have failed at the same time...

    More likely the receiver section or board has lost its power supply or there is a beak in the track supply power to that section. Chances of someone coming on here and needing to ask and being able to successfully fix the fault, nil.
     
    • Like Like x 1
  8. Sponsored Links
Loading...

Share This Page