1. Visiting from the US? Why not try DIYnot.US instead? Click here to continue to DIYnot.US.
    Dismiss Notice

potterton suprema 80 heating side not firing up

Discussion in 'Plumbing and Central Heating' started by blackjack100, 8 Nov 2009.

  1. blackjack100

    blackjack100

    Joined:
    8 Nov 2009
    Messages:
    3
    Thanks Received:
    0
    Location:
    Essex
    Country:
    United Kingdom
    Hi

    Wonder if anyone can help

    I have the above boiler and the hot water side is fine, fires up when it should on timer and manual no problem but the central heating side will not fire up on timer or manual.

    I have had the pcb out to look over it but haven't got a magnifying glass to look closer. The central heating side has started a couple of times but just stops and wont fire up again. I have had no lock outs just the central heating side not working.

    Any suggestions please as I know the PCB on these is suspect but as I have had no lock outs and the hot water is ok I thought I’d ask.

    Cheers

    Chris
     
  2. Sponsored Links
  3. kevplumb

    kevplumb

    Joined:
    18 May 2004
    Messages:
    23,713
    Thanks Received:
    925
    Location:
    depends where i get sent
    Country:
    United Kingdom

    check the 3 port valve is working ok :idea:
     
  4. baxpoti

    baxpoti

    Joined:
    15 Dec 2006
    Messages:
    4,491
    Thanks Received:
    557
    Country:
    United Kingdom
    Another clue..........

    the boiler is either on or off it doesn't know whether it's heating your radiators the hot water or next doors swimming pool.
     
  5. kevplumb

    kevplumb

    Joined:
    18 May 2004
    Messages:
    23,713
    Thanks Received:
    925
    Location:
    depends where i get sent
    Country:
    United Kingdom
    [​IMG]

    he hasn't noticed the tee heating my pool yet [​IMG]
     
  6. blackjack100

    blackjack100

    Joined:
    8 Nov 2009
    Messages:
    3
    Thanks Received:
    0
    Location:
    Essex
    Country:
    United Kingdom
    The 3 port has been making a load buzzing noise for quite some time now so will check it out.

    Also can I assume from baxpoti's post (which of course he is correct) that I can rule out any sensors on the boiler itself?

    Neither of you have indicated a PCB prob so can we rule that out also or am I jumping the gun a little here.

    Cheers

    Chris
     
  7. kevplumb

    kevplumb

    Joined:
    18 May 2004
    Messages:
    23,713
    Thanks Received:
    925
    Location:
    depends where i get sent
    Country:
    United Kingdom
    no get the valve checked/sorted first ;)

    if it was a boiler prob it would be playing up on either :idea:
     
  8. blackjack100

    blackjack100

    Joined:
    8 Nov 2009
    Messages:
    3
    Thanks Received:
    0
    Location:
    Essex
    Country:
    United Kingdom
    ok will check it out, thanks for the replies so quickly.

    chris
     
  9. DIYnot Local

    DIYnot Local

    Joined:
    3 Sep 2019
    Country:
    United Kingdom

    If you need to find a tradesperson to get your job done, please try our local search below, or if you are doing it yourself you can find suppliers local to you.

    Select the supplier or trade you require, enter your location to begin your search.


    Are you a trade or supplier? You can create your listing free at DIYnot Local

     
  10. Sponsored Links
Loading...

Share This Page