Ravenheat CSI 120T turns on and off every 8 mins.

Joined
1 Sep 2019
Messages
4
Reaction score
0
Country
United Kingdom
i have a Ravenheat boiler that for some reason turns it self on for a minute or so then turns itself off, even with winter or summer switch settings.
It has no leaks and 1.5 Bar pressure.
So I presume it’s to do with the Hot water
Faulty flow switch or faulty flow sensor ?
 
Sponsored Links
Joined
15 Aug 2010
Messages
24,964
Reaction score
11,165
Location
Livingston
Country
United Kingdom
Sounds like the DHW flow switch is sticking, do you have any dripping taps or water leaks anywhere ?
 
Joined
1 Sep 2019
Messages
4
Reaction score
0
Country
United Kingdom
No nothing that I can find I’ll disconnect the flow switch to see if it stops it happening.
 
Joined
15 Aug 2010
Messages
24,964
Reaction score
11,165
Location
Livingston
Country
United Kingdom
if the display is showing the HW demand icon when the boiler is ghost firing that is your problem
 
Sponsored Links
Joined
1 Sep 2019
Messages
4
Reaction score
0
Country
United Kingdom
I disconnected the Hot water Thermistor or DHW/CH SENSOR that stopped the problem.
New one ordered hopefully that will cure it.
RAVENHEAT 0007TER05005/0
 
Joined
15 Aug 2010
Messages
24,964
Reaction score
11,165
Location
Livingston
Country
United Kingdom
I disconnected the Hot water Thermistor or DHW/CH SENSOR that stopped the problem.
New one ordered hopefully that will cure it.
RAVENHEAT 0007TER05005/0
Probably wont all you have done is create a fault to prevent the boiler from coming on
 
Joined
1 Sep 2019
Messages
4
Reaction score
0
Country
United Kingdom
You must be thinking of a different boiler as mine ignites / comes on when hot tap is opened ( with it still disconnected.)
 
Joined
15 Aug 2010
Messages
24,964
Reaction score
11,165
Location
Livingston
Country
United Kingdom
You must be thinking of a different boiler as mine ignites / comes on when hot tap is opened ( with it still disconnected.)
No I know your boiler, so prey tell me what tells the boiler what the temperature of the primary or secondary circuits are now at, since you have disconnected the sensors and left them open circuit ?
 
Sponsored Links
Top