Salus RT520TX stopped working

Discussion in 'Plumbing and Central Heating' started by Jennifer Lancaster, 4 Apr 2020.

  1. Jennifer Lancaster

    Jennifer Lancaster

    Joined:
    4 Apr 2020
    Messages:
    2
    Thanks Received:
    0
    Country:
    United Kingdom
    Hello my Salus RT520TX has been working perfectly for 5 months and now it is only showing this on the screen. None of the buttons are doing anything when pressed. I have tried changing the batteries and resetting but still nothing.. can anyone help? upload_2020-4-4_23-11-39.jpeg
     
  2. muggles

    muggles

    Joined:
    28 Oct 2005
    Messages:
    13,431
    Thanks Received:
    3,104
    Location:
    Daventry
    Country:
    United Kingdom
    Have you tried the factory reset procedure?

    Screenshot_20200405-074749_Drive.jpg
     
  3. Sponsored Links
  4. Jennifer Lancaster

    Jennifer Lancaster

    Joined:
    4 Apr 2020
    Messages:
    2
    Thanks Received:
    0
    Country:
    United Kingdom
    hello thank you for your reply yes i tried that too and nothing is happening
     
  5. muggles

    muggles

    Joined:
    28 Oct 2005
    Messages:
    13,431
    Thanks Received:
    3,104
    Location:
    Daventry
    Country:
    United Kingdom
    Sounds like it's goosed then. They have a 5 year warranty so if you contact Salus they should sort it for you
     
    • Thanks Thanks x 1
    • Like Like x 1
  6. DIYnot Local

    DIYnot Local

    Joined:
    3 Sep 2019
    Country:
    United Kingdom

    If you need to find a tradesperson to get your job done, please try our local search below, or if you are doing it yourself you can find suppliers local to you.

    Select the supplier or trade you require, enter your location to begin your search.


    Are you a trade or supplier? You can create your listing free at DIYnot Local

     
  7. Sponsored Links
Loading...

Share This Page