Swap Swann DVR for Hikvision - is it possible?

Joined
27 Feb 2017
Messages
22,035
Reaction score
2,278
Location
Essexshire
Country
United Kingdom
Solely because I can't get the Swann app to work anymore on our phones and iPads, I was thinking of changing the DVR unit. I have what I believe are BNC cables to my Swan cameras. It it just a simple matter of swapping the DVR unit - my Swann has 4 camera's, a power socket, a HDMI socket for connection to my TV in the lounge, a LAN port and a USB mouse port - I use a cordless mouse from the lounge.

Does the Hikvision app work fine with no glitches?

I'm looking at one of these: https://www.ebay.co.uk/itm/113040240490

Edit. Does anyone know a generic cctv app that may work with the Swann CCTV?
 
Last edited:
Joined
20 Jun 2014
Messages
5,772
Reaction score
751
Location
Lancashire
Country
United Kingdom
well I guess that depends on the resolution of your cameras and the technology they are using.
 
Sponsored Links
Joined
27 Feb 2017
Messages
22,035
Reaction score
2,278
Location
Essexshire
Country
United Kingdom
well I guess that depends on the resolution of your cameras and the technology they are using.
It's the cameras from this kit.
44AC4B90-BD78-4450-8769-B6FD5C2792ED.jpeg
 
Joined
27 Feb 2017
Messages
22,035
Reaction score
2,278
Location
Essexshire
Country
United Kingdom
Update: the box in the picture that I took the cameras from also contained a new DVR. Then I remembered - a few years ago my DVR packed up so I bought a new kit with better cameras. When I connected it up using the old power supply, it didn't work - it was the power supply being faulty that has stopped the original one from working in the first place! Long story short(ish), I used the cameras and power supply from the new kit and kept the new DVR as a spare. I tried plugging that in last night but had forgotten the password so I refitted the original DVR back......and everything worked! I could now view the cameras on mine and my wife's iPads and iPhones just as before. I could always view the CCTV from my lounge on the TV as it's connected by a very long HDMI cable. I'm just wondering if it was a bad connection on the ethernet cable that was cured by unplugging and plugging it back in that's made it work on the phones again?
 
Sponsored Links
Top