Texecom elite 48 part alarm issue

17 Aug 2022
Reaction score
United Kingdom
I have a Texecom elite 48 (V6.02) with Smartcom (V4.01). Its been fine for the last couple of years, but now my little granddaughter has started to stay over some nights with us I decided to use the part alarm function to disable most of the PIR's downstairs in case she goes for a wander at night !
The Full Alarm button works fine as a way to Quick Arm as we leave the house - no issues there.

I'm using Wintex to monitor and program via IPcom. I have ticked the "Part 1 Omit" in all of the zones I want to disable. I am only using area A.

But when I push the Part Alarm button all I get is a message saying "Suite01 ArmArea / A..." After 10 seconds this goes off and alarm is still disarmed.

I'm struggling to see what I've missed in the setup !
Can anyone give me some pointers ?

Sponsored Links
Just found out if I push the 'Part Alarm' button twice and then push the 'Yes' button it seems to work OK. The alarm is set and works fine. I've now added text into the screen for the 3 part alarms so I can see what's going on better.
So pushing the part set button twice takes me to part alarm 1, pushing 3 times takes me to part alarm 2 and so on. Using the direct 1, 2 or 3 buttons to select the part alarm doesn't seem to work !

Is this the way its supposed to work ? ?
Yep, I'd agree with you there. I'm just unsure as to how to remove the suite ?

I have the following screens from the Areas tab :-

Do I just remove area 'A' from the 'Suite 1', in the second image ? This is the only reference to suits I can find.
I don't ever remember adding anything like this 2 years ago when I initially programmed it !

area timers.png
Sponsored Links
Press part arm twice will take you to area arm suites and then part options

Once you unprogram the area arm suites then you should be able to press part arm once and it take you directly to part arm options
I unprogrammed the suites as below.
The alarm does absolutely nothing now, I cannot arm it all by entering codes or keyfobs or pressing quick arms, either full or part.
I think I'm looking at complete factory reset and start again !
suites off.png
I think I've cracked it.

The "Use Keypad Areas" under the keypad options was unselected ! ?

From the manual it says :-
When selected, the keypad sounder and arming control is determined by the area that the keypad is assigned to.
When deselected, the keypad becomes an ‘Area Arm Suite’ controller (see page 62 for details). This allows different combinations of areas to be armed or disarmed depending on which keypad is used and operates as follows:
• Keypad 1 = Area Arm Suite 1, Keypad 2 = Area Arm Suite 2, Keypad 3 = Area Arm Suite 3 etc.

All seems to work as expected now - Instant arming on pressing the Area button, Part arming on pressing the Part button. Full control of the keypad too.

Learn something new everyday eh ?
Last edited:
Sounds like your on the righttrack takes a few seconds to update test to confirm

DIYnot Local

Staff member

If you need to find a tradesperson to get your job done, please try our local search below, or if you are doing it yourself you can find suppliers local to you.

Select the supplier or trade you require, enter your location to begin your search.

Are you a trade or supplier? You can create your listing free at DIYnot Local

Sponsored Links