Texecom Elite premier can arm but not disarm from keypad

7 Oct 2021
Reaction score
United Kingdom
Been pulling my hairs out over this. Got a new self install system (elite 64w with smartcom, 1 wired keypad and 1 wireless keypad) and everything is almost working perfectly, exepct for one thing - I cannot disarm from either keypad (wired or wireless). I am however able to disarm by keying in the same user codes through Wintex virtual keypad, or through using the Texecom app on my phone. I type in the user code, choose part arm and select my part arm and it arms fine. Then once armed, if I enter the code, I get the option to disarm, but it just beeps and exits the menu. I've checked the logs, and there is nothing there relating to the failure of the disarm.

I've ready through a lot of posts and gone through the installation manual looking at every setting. Everything is set up on a single area, with some zones configured as omit for part arms. I've set up the keypad not to use keypad areas, I've turned off the default custom outputs which relate to the timer c lock, I've unticked "local arming/disarming" for my user, ive turned off EN50131 checkboxes in settings but nothing seems to work. Those are all the obvious ones I have from other posts but I have also tried changing many things and I just cant work it out. I've not tested this disarming from full arm because I only get the chance to try this out in the evenings and a full arm would need me to get the whole family out the house, but really it shouldnt be this hard.

Please can someone help! I've uploaded some screenshots of my settings.

Thanks in advance for any ideas to solve this


  • global settings.PNG
    global settings.PNG
    521.8 KB · Views: 81
  • keypad options.PNG
    keypad options.PNG
    217.3 KB · Views: 102
  • area options.PNG
    area options.PNG
    208.6 KB · Views: 101
  • area options2.PNG
    area options2.PNG
    319.8 KB · Views: 98
  • user config.PNG
    user config.PNG
    239.8 KB · Views: 90
  • outputs.PNG
    540 KB · Views: 88
Sponsored Links
Not sure where the best place is to start as you have been fiddling with lots of different things.

it may be better to start with how you would like things to work and start from scratch ish to straighten it all out.

what addresses are the keypads you are using, just you have two keypads and showing address 4 in wintex programming.

so you can arm but not disarm from the hardwired and wireless keypad?
the event log should show sequence of events, from arming to enter code prior to disarming.

It’s late and I am tired, so

the fact you say it works in wintex keypad would suggest to look at keypads and there programming first.
Thanks, that was might thought too, its either a keypad configuration issue or something to do with only remote disarming. Interesting question you ask as I have not been able to work out which keypad is which, so I keep setting them all up the same. From the moment I installed, it showed those 4 keypads in Wintex, is it only supposed to show whats actually connected?

Yes I can arm from both hardwired and wireless keypad, but cant disarm - it just beeps and exits menu when I try disarm. I can disarm from the mobile app or from Wintex keypad. Auto disarm on timer works as well. Not tried the prox but I got a prox sensor today which I will try out this evening just to see.

I've also not been able to work out how to identify each keypad, is it just a case of the Address number which you can work out from the DIL switch positions is the keypad number (using the table in the keypad installation manual showing Address and DIL on/off positions) ? Any idea if there is a way to remove the keypads. You've just struck a thought in my head, I randomly changed one of the DIL switches on my wired keypad to make it unique from the wireless keypad. Perhaps if I have keyboard 1 and 4 enabled it doesnt like it, maybe they need to be sequentially used, I'll check that this evening. That could posibly explain why it shows 4 keypads even though I only have 2.

I've attached an image showing the log. You'll see the part arm event, and then shortly afterwards a disarm from remote (using the app). In between there, not shown in the log is the action of me attempting to disarm from the keypad, it doesnt log the event nor an error relating to the failed disarm, not very helpful! You'll see if armed it from a different user, but I have tried disarming it from both the master, my wife's user and my user, the latter of the 2 have identical configurations, but all have the same behaviour. You can see the event "system access by user 03- Amanda", and thats when I try disarm, nothing happens and no logs. Then at 21:06:06 I used the app to disarm.



  • log.PNG
    130.5 KB · Views: 89
if you haven't changed the dip switches on the keypads they will be both address 1.

We can see Amanda armed from keypad one using area arm suite 1, (part arm suite 1).
You only have one Area so no need for Area arm suites, these are really for bigger panels and arming a selection of areas from a keypad near by, but you can use them, that in itself shouldn't be an issue.

if you press Yes and Menu on the keypads you should see ADD00X where x is the address of the keypad.
if struggling with the wireless keypad to do this open it up and look at the address switches.

in wintex you should be able use the keypad and do confirmed devices and you should have RKP keypad addresses (you should have two addresses as you have 2 keypads), and EXP expander addresses.

You can also go into the virtual keypad (4) setup keypads, and see the keypads that are in use marked with an *.
Sponsored Links
So after investigation, I found the keypads had their addresses configured correctly, i.e. Wired keypad was address 2 and wireless was address 1, so no conflicts. I performed a Default NVM data first on the areas, still didnt work, and then I did a reset on the Keypads, and that seemed to do the trick. Even though I have now set all the checkboxes exactly as they were before!!

I also learnt with your little helper there clicking the tick and menu at the same time, you can get to the keypad options such as button press click sound and brightness, very helpful to know! I searched all over for how to turn off beeps on the texecom premier keypad and could not find anything, so thanks for that!

Many thanks for your help
Last edited:

DIYnot Local

Staff member

If you need to find a tradesperson to get your job done, please try our local search below, or if you are doing it yourself you can find suppliers local to you.

Select the supplier or trade you require, enter your location to begin your search.

Are you a trade or supplier? You can create your listing free at DIYnot Local