Texecom Smartcom app not working

Joined
27 May 2022
Messages
6
Reaction score
0
Country
United Kingdom
Hi sorry for a longer post, just trying to give as much detail as possible.

I have recently moved into a house with a Texecom Elite 48 alarm ('menu - 4' shows sw v5.01.02.LS1) with a smartcom module installed.

Over the past week or so I have been investigating the configuration of the alarm system. After getting hold of the manual I was able to reset the engineer code which then enabled me to resolve a couple of issues with some of the sensors. As such the alarm is now functioning correctly.

My next goal is to configure the Texecom app.
Looking online it seems like a panel has to be connected to an installer's texecom cloud account for the v2 app to work, as such I have created a cloud account, created a site and attempted to connect to the panel but this fails.

I am able to successfully generate an app code from the keypad however when arc 1 is configured as Texecom connect the panel periodically shows “ATS failed”. Additionally, when using the app code it doesn't seem to work.
in Wintex (smartcom connect), I see "connection to the control panel could not be established"
in the app, after logging in, i see "Error syncing with the panel"
in the texecom cloud 'connect to a panel' dialog (logged in with a different account to above), i see "Response from comms was null"

The smart com 4 pin lead is connected to the panels' com 1 and the 2 pin lead to com 2; the internet connection is provided via WiFi.
Com Ports.JPG


On the smartcom device the LEDs are showing as; Cloud - Flashing, WiFi - solid on, Ethernet - off, power - solid on. In the router control panel, Parental controls are not configured and the 'texe_hub' device shows as connected to the network with internal ip 192.168.1.146 (dhcp).

Most recently i have tried setting the smartcom up from scratch by completing the following:
I have reset the UDL code to the new engineer code
Set all ARC protocols to disabled,
Set all Panel Com ports Options to Nothing FItted
Disconnected the smart com from both com ports
logged out of the engineer user
logged into the engineer user
reconnected the smart com to the panel com ports
reset comp ports to com 1 - smart com, com 2 - comIP
reset arc 1 to texecom connect
reset the smartcom wifi (5 presses), and then reconnected it to the network
logged out of the engineer user

I still see the same errors in all 3 locations.

I am able to connect to the panel through Wintex connect via ip but not by Smartcom the current comms configuration is shown below
wintex-com-port-options-jpg.270777
Wintex ARCs.JPG


Any recommendations on the best process to get the cloud connection working or next steps would be greatly appreciated.

Thanks

Nik
 

Attachments

  • Wintex Com port Options.JPG
    Wintex Com port Options.JPG
    126.3 KB · Views: 310
Last edited:
Sponsored Links
Joined
27 May 2022
Messages
6
Reaction score
0
Country
United Kingdom
I think it’s v02.01.05 but not 100% sure. if you let me know how to check I will verify.
 
Joined
20 Jun 2014
Messages
5,901
Reaction score
784
Location
Lancashire
Country
United Kingdom
Can you see it in the portal?
If yes it will tell you version and you can update it till latest version.
 
Sponsored Links
Joined
27 May 2022
Messages
6
Reaction score
0
Country
United Kingdom
In the portal i don't see any panel information, instead, i see "Site is pending a panel connection, click 'Connect to Panel' to continue"

When I attempt to connect the panel it asks for the app code and engineer passcode. after entering these it shows " Connecting to alarm system to identify panel and validate engineers code..." for about 30 seconds then i get "Response from comms was null
The system has failed to verify connection to the panel for the above reason. Click the 'Retry' button if you would like to attempt the verification again:
"
 
Joined
27 May 2022
Messages
6
Reaction score
0
Country
United Kingdom
Thanks for the suggestion, I have changed that setting now but still get the same errors when trying to use the app code.
 
Joined
27 May 2022
Messages
6
Reaction score
0
Country
United Kingdom
i have emailed the technical support address yesterday night, haven't had any answer yet though.
 
Joined
27 May 2022
Messages
6
Reaction score
0
Country
United Kingdom
Quick update I have heard back from Texecom support who have confirmed the following.

If the Smartcom is v2.01.05 or lower, it will generate an app code but no longer function with the Cloud. In this instance the Smartcom would need to be replaced with a new unit. There was a critical security update the was pushed out to all Smartcoms that were online, if the Smartcom was not online, it will have missed the update and it now cannot be updated.

I will get the unit replaced and hopefully this will resolve the issue. Thanks for the help and suggestions and checking I hadn't missed anything obvious.

Nik
 

DIYnot Local

Staff member

If you need to find a tradesperson to get your job done, please try our local search below, or if you are doing it yourself you can find suppliers local to you.

Select the supplier or trade you require, enter your location to begin your search.


Are you a trade or supplier? You can create your listing free at DIYnot Local

 
Sponsored Links
Top