The Grundfos upm3 pump does not stop running

4 Nov 2022
Reaction score
Czech Republic
Hello to everyone,

I have a problem with my Grundfos upm3 pump that does not stop running.
Here is the description of the problem:

  1. I have two heating circles, upstairs and downstairs which is floor heating. The pump in the question services the floor heating.
  2. It is connected with Junkers heater.
  3. The heating was turned off since the end of the winter this year, end of March 2022
  4. The heating is still turned off ....
  5. ... but sometimes in the middle of September 2022 the pump started to turn on on its own. It turned on at around 6 o'clock in the morning and run for about 3 hrs. No hot water was pumped as the heater did not indicate anything and I could hear it did not work or better said I checked the pipes in and out of the pump, both were cold.
  6. I reset the heater, did not help.
  7. I reset the pump itself by unplugging the whole set from the electricity, it helped as far as I could say.
  8. Then I went for vacation for two weeks, the whole heating system was set on Holiday mode.
  9. I do not know whether the pump worked or not, but heater was off as I checked the gas consumption before leaving and after coming back.
  10. On November 2nd came back and turned the heating on. The heating worked fine, but even after reaching and exceeding the desired temperature, pump still works.
  11. The other pump (upstairs) is off as expected.
  12. The pump pumps the water for 24 hrs non stop. I did see one small break, of course I do not monitor it 24 seven. However it worked all night if nothing else.
  13. I reset the heater, unplugged pumps from the electricity and also reset it by pressing the reset button. No help.
  14. So at the end, the pump pumps cold water in my floor heating and I do not know how to stop it. It shows one green and one orange light.
Is it perhaps a desired behavior? First I thought it was some kind of antifreeze as when this behavior occurred it was around 5 degrees Celsius outside, but still 18 inside. Now I think it might be an attempt to clean the system, but as I am probably the only one with this problem, I did not manage google anyone with this problem so I am a little desperate.

I contacted the seller, but no response. Which is weird, because when we had other problems, they promptly sent someone over, despite at the end I could do it myself.

Any help would be appreciated.

Thank you
Last edited:
Sponsored Links
Sounds like it’s receiving a feed from somewhere.

DIYnot Local

Staff member

If you need to find a tradesperson to get your job done, please try our local search below, or if you are doing it yourself you can find suppliers local to you.

Select the supplier or trade you require, enter your location to begin your search.

Are you a trade or supplier? You can create your listing free at DIYnot Local

Sponsored Links