Triton T80SI going hot then cold

Joined
25 Feb 2010
Messages
154
Reaction score
7
Location
Angus
Country
United Kingdom
Hi,
Got a triton T80si shower last january from tritons ebay clearance store.

On setting 2 the temp is going hot them cold, but if you have it on setting 1 the shower is fine & temp stays the same.

Any idea on how it would do this on setting 2?
 
Joined
30 Dec 2018
Messages
10,762
Reaction score
1,455
Country
United Kingdom
Hi,
Got a triton T80si shower last january from tritons ebay clearance store.

On setting 2 the temp is going hot them cold, but if you have it on setting 1 the shower is fine & temp stays the same.

Any idea on how it would do this on setting 2?

Electric shower!

It does not have enough flow of water, so rather than burn you, itself shuts off for safety. You are turning it up too high, or the water pressure is too low, or there is a restriction in the flexible pipe, or the shower head. Quick check - remove the head, does it work OK then?

Are you in a hard water area?
 
Sponsored Links
Joined
25 Feb 2010
Messages
154
Reaction score
7
Location
Angus
Country
United Kingdom
Electric shower!

It does not have enough flow of water, so rather than burn you, itself shuts off for safety. You are turning it up too high, or the water pressure is too low, or there is a restriction in the flexible pipe, or the shower head. Quick check - remove the head, does it work OK then?

Are you in a hard water area?
actually just googled how to check the water pressure, at the kitchen sink it's filling a 1ltr jug in just over 3 seconds

no, we're in a soft water area, Angus Scotland

as i said, it works fine when on setting 1, which should say the hoses & heads are ok?
Will take them off and clean them
 
Joined
30 Dec 2018
Messages
10,762
Reaction score
1,455
Country
United Kingdom
Flow and pressure are two completely different things, though usually associated. Most likely - the head, try the hose without the head fitted.
 
Sponsored Links
Top