Vaillant ecofit pure keeps erroring

Discussion in 'Plumbing and Central Heating' started by Bl888, 17 Jan 2021.

  1. Bl888

    Bl888

    Joined:
    30 Jul 2013
    Messages:
    91
    Thanks Received:
    4
    Location:
    Surrey
    Country:
    United Kingdom
    Hi all

    wondering if I can get some advice. We have a vaillant ecofit pure boiler and it seems to keep crashing frequently with either error code 20 or 23. The whole system crashed and we need to restart it.

    conntected to system is a gledhill hot water tank, pressure tank in loft, rads and underfloor heating in kitchen/diner.

    any ideas what could keep causing this? As days we get no hot water as we don’t realise it’s failed.
     
  2. Sponsored Links
  3. rbranco

    rbranco

    Joined:
    27 Jan 2018
    Messages:
    182
    Thanks Received:
    23
    Country:
    United Kingdom
  4. Bl888

    Bl888

    Joined:
    30 Jul 2013
    Messages:
    91
    Thanks Received:
    4
    Location:
    Surrey
    Country:
    United Kingdom
    I notice it tends to improve when I let air out of the magna flow bottle.

    i did notice sometimes the pump loses power and the boiler stays on.

    maybe pump on the way out?

    Any recommendations for a good powerful pump to service a 5 bedroom house with large number of rads and Tank. The underfloor system has its own pump in the utility
     
  5. rbranco

    rbranco

    Joined:
    27 Jan 2018
    Messages:
    182
    Thanks Received:
    23
    Country:
    United Kingdom
    Well if you keep having air in there, then that needs to be looked at first, clearly there is a leak and air is being pulled into system.

    Which pump looses power?

    Where is the UFH pump installed?
     
  6. Bl888

    Bl888

    Joined:
    30 Jul 2013
    Messages:
    91
    Thanks Received:
    4
    Location:
    Surrey
    Country:
    United Kingdom
    ufh pump is installed downstairs in the utility.

    it’s the central heating pump that loses power which is a grunfos alpha 2L

    don’t seem to be having any leaks anywhere though
     
  7. Bl888

    Bl888

    Joined:
    30 Jul 2013
    Messages:
    91
    Thanks Received:
    4
    Location:
    Surrey
    Country:
    United Kingdom
  8. CBW

    CBW

    Joined:
    26 Sep 2019
    Messages:
    9,708
    Thanks Received:
    2,653
    Location:
    North
    Country:
    United Kingdom
    Check your magnaclean isolation valves and any other isolation valves as well.
     
  9. Bl888

    Bl888

    Joined:
    30 Jul 2013
    Messages:
    91
    Thanks Received:
    4
    Location:
    Surrey
    Country:
    United Kingdom
    thanks for the reply what am I checking exactly?
     
  10. Sponsored Links
  11. rbranco

    rbranco

    Joined:
    27 Jan 2018
    Messages:
    182
    Thanks Received:
    23
    Country:
    United Kingdom
    Is this an open vent?
    Is there a TRV, does pump stay on after boiler stops firing?

    You have a negative pressure leak, air is drawn in not water going out. How else is air getting in.
     
  12. rbranco

    rbranco

    Joined:
    27 Jan 2018
    Messages:
    182
    Thanks Received:
    23
    Country:
    United Kingdom
    According to manual, there need to be a TRV between the main pump and boiler return, also pump needs to be wired direct to boiler and not via wiring center.

    Im sure the ecofit has minimum flow rates which means TRV and pump on fixed speed should be set I think.

    I have a 418 ecotec and that is the way mine is setup.
     
  13. CBW

    CBW

    Joined:
    26 Sep 2019
    Messages:
    9,708
    Thanks Received:
    2,653
    Location:
    North
    Country:
    United Kingdom
    These circled blue, they have on/off indicators, make sure they both say on. Make sure any other valve including any under the boiler are in line with the pipe.
     

    Attached Files:

  14. rbranco

    rbranco

    Joined:
    27 Jan 2018
    Messages:
    182
    Thanks Received:
    23
    Country:
    United Kingdom
    Does the boiler trip only when HW is requested or also when CH is turned on?
     
  15. Bl888

    Bl888

    Joined:
    30 Jul 2013
    Messages:
    91
    Thanks Received:
    4
    Location:
    Surrey
    Country:
    United Kingdom
    most of the time when the hot water comes on about 5pm
     
  16. Bl888

    Bl888

    Joined:
    30 Jul 2013
    Messages:
    91
    Thanks Received:
    4
    Location:
    Surrey
    Country:
    United Kingdom
    Yeap both set to on.

    it doesn’t trip all the time. Tends to do it 2 out of 5 days which is bozarre
     
  17. Bl888

    Bl888

    Joined:
    30 Jul 2013
    Messages:
    91
    Thanks Received:
    4
    Location:
    Surrey
    Country:
    United Kingdom
    I have an expansion vessel in the loft and a seperate vessel for the hot water tank.
    Pump stays on to keep circulating I think
     
Loading...

Share This Page