vauxhall vivaro 53 plate 1.9 diesel HELP PLEASE

Joined
7 Apr 2010
Messages
4
Reaction score
0
Location
Gwent
Country
United Kingdom
can anyone tell me what are the signs that the crank shaft sensor has gone or is going on the vauxhall vivaro? when i start it in the morning i have no revs for about 5 minutes then it just shoots up i am then able to drive as normal it also blows white smoke.it has recentley got worse & now when i pull off i have no power.i have changed the cam shaft sensor,the egr valve,the air filter,the diesel filter & the mass air flow sensor.my engine managment light is not on.after having trying almost everything someone has now suggested it could be the crank shaft.any info really appreciated as i am now at a loss ,thanks michelle :confused:
 
Sponsored Links
Joined
26 Sep 2006
Messages
1,838
Reaction score
278
Location
Dorset
Country
United Kingdom
I,m afraid I don't know a lot about modern diesels, all mine are IDIs, nice and simple, but white smoke is a sign of unburnt fuel,it could be that the timing is out, but that would normally make it difficult to start, I think a faulty crank shaft sensor would prevent it from starting. If I were you I would take along to a diesel specialist, they usually know what they are doing and don't charge the earth.

Peter
 
Joined
16 Jan 2006
Messages
2,994
Reaction score
293
Location
Newport, S Wales.
Country
United Kingdom
crank sensors usually cause non start problems not the symptoms you describe.
I see your in gwent, merthyr tydfil college have a specialist diesel diagnostic centre on site and its very good and not expensive.
 
Joined
7 Apr 2010
Messages
4
Reaction score
0
Location
Gwent
Country
United Kingdom
thanks for the info i have tried to get a diesel expert to look at it but there is a month waiting b4 they can take a look so i will be trying merthyr thanks again
 
Joined
14 Jun 2006
Messages
1,707
Reaction score
43
Location
Surrey
Country
United Kingdom
I'd get the timing checked as mentioned above. I'm pretty sure yours is a chain drive and the chains can stretch. May only knock it out a bit, but can be enough to give grief
 
Joined
19 May 2011
Messages
2
Reaction score
0
Country
United Kingdom
can anyone tell me what are the signs that the crank shaft sensor has gone or is going on the vauxhall vivaro? when i start it in the morning i have no revs for about 5 minutes then it just shoots up i am then able to drive as normal it also blows white smoke.it has recentley got worse & now when i pull off i have no power.i have changed the cam shaft sensor,the egr valve,the air filter,the diesel filter & the mass air flow sensor.my engine managment light is not on.after having trying almost everything someone has now suggested it could be the crank shaft.any info really appreciated as i am now at a loss ,thanks michelle :confused:

Condition of my friend's vivaro is quite the same.. Motor revs up then shoots up to over 2000 RPM's. It settles down to normal after 5 Minutes but this happened after he installed his air filter from Scantech parts.. His engine light does not light up either.. What was the diagnosis with your vivaro?
 
Sponsored Links
Top