Worcester Greenstar - Pump problem

Joined
21 Apr 2008
Messages
118
Reaction score
1
Location
Lincolnshire
Country
United Kingdom
OK guys- new problem lol...

My boiler is working fine- call for heating works, boiler turns on, heats the water up and pumps away until satisfied etc...

But I have noticed that for some reason while working away whilst giving CH it will randomly stop heating but what is even more strange is the pump will also stop resulting in the temperature on the boiler hitting 90degrees (basically no overrun). Then I think it basically resets itself going all the way back down to 30 degrees (which when the pump is not working takes a while).

The pump definitely works because when you unplug it from the 24v circuit it stays continually on...

Does this sound like a faulty PCB? As I say this only happens during the CH mode.
 
Sponsored Links
Joined
21 Apr 2008
Messages
118
Reaction score
1
Location
Lincolnshire
Country
United Kingdom
It's a 2006 greenstar 35cdi
It's been a pain to diagnose because I never noticed it creeping up from 60 to 90 as the boiler was always silent when it did it!
Wonder what caused that to happen on pcb
 
Sponsored Links
Joined
21 Apr 2008
Messages
118
Reaction score
1
Location
Lincolnshire
Country
United Kingdom
Wonder if it's worth me having a go at replacing the relay?
Is it within the board itself?
I imagine having a power cut a few weeks ago maybe caused it.
 
Joined
21 Apr 2008
Messages
118
Reaction score
1
Location
Lincolnshire
Country
United Kingdom
hi again- i had a look today but definately can't seem to find any relays on that board. is the relay defiantly on the PCB
 

DIYnot Local

Staff member

If you need to find a tradesperson to get your job done, please try our local search below, or if you are doing it yourself you can find suppliers local to you.

Select the supplier or trade you require, enter your location to begin your search.


Are you a trade or supplier? You can create your listing free at DIYnot Local

 
Sponsored Links
Top