xplelair sl100ht bathroom extractor fan

Joined
19 Aug 2005
Messages
386
Reaction score
15
Location
Cheshire
Country
United Kingdom
I have fitted the above fan and wired it just to permanent live and permanent neutral via a fused spur , I dont want the option to just pull a cord to turn it on as well , I just want it to operate on humidity . Since powering it up the fan is just staying on constantly , altering the two controls does nothing at all .One control is the humidity setting and the other is how long it would stay on if I had fitted the pullcord . Any ideas as this is brand new and I know its under warranty but surely the fan should not be on now ??????
 
Sponsored Links
Joined
19 Aug 2005
Messages
386
Reaction score
15
Location
Cheshire
Country
United Kingdom
No , not connected the switched live and the led that would be on if there was power to that terminal is off .
 
Joined
19 Aug 2005
Messages
386
Reaction score
15
Location
Cheshire
Country
United Kingdom
Mode can't be set can it ? It is auto humidity and switched override ?? I have tried it with the humidity dial (blue one ) fully anticlockwise - most sensitive , mid position and fully clockwise - least sensitive .
 
Sponsored Links
Joined
19 Aug 2005
Messages
386
Reaction score
15
Location
Cheshire
Country
United Kingdom
The unit has an led that comes on if power is supplied to the switched live terminal via a pullcord , this has not been connected to anything and the led is off ,this fan is brand new and I think it must just be a faulty unit .
 
Joined
30 Jun 2009
Messages
21,627
Reaction score
2,567
Location
Londonderry
Country
United Kingdom
Does the LED light come on when in manual mode, as I understand it should.
You have only connected twin core cable (phase and neutral)+CPC(earth) to the device, via a two pole isolator?
And set the timer to minimum time?
 
Joined
15 Nov 2005
Messages
77,089
Reaction score
4,781
Location
Crossgates, Europe
Country
Cook Islands
try connecting it the way the makers say, including the switch. Does it work correctly then? You haven't got to pull the cord if you don't want to, especially if you have an aversion to ventilation.

If it has an electronic control module perhaps you are confusing it.
 
Joined
19 Aug 2005
Messages
386
Reaction score
15
Location
Cheshire
Country
United Kingdom
I spoke to Xpelair tech help this morning and she was very unhelpful , she insisted that without a wire connected to the SL terminal then it would not work as a humidistat fan . I told her I would now wire it up including a switch. I wired it up as per instructions and guess what it is exactly the same , the only difference is that when I turn on the switch the led is now lit . I again spoke to tech help and he instantly said "yeah its knackered , the humisistat will be faulty , I will send you a new pcb " but he also said the fan was manufactured in 2009 even though I bought it brand new 2 weeks ago , guess someone has a stockpile of these :)
 
Sponsored Links
Top