1. Visiting from the US? Why not try DIYnot.US instead? Click here to continue to DIYnot.US.
    Dismiss Notice

British Gas WL2 thermostat / receiver not pairing

Discussion in 'Plumbing and Central Heating' started by Chris Campbell, 27 Jan 2021.

  1. Chris Campbell

    Chris Campbell

    Joined:
    27 Jan 2021
    Messages:
    9
    Thanks Received:
    0
    Country:
    United Kingdom
    Hi all.

    I've done some digging around the web and on the forum and can see others have succeeded in reconnecting / pairing the thermostat with the receiver using the hive instructions here as the models are similar via a previous thread:

    https://www.diynot.com/diy/threads/...d-of-instructions.478711/page-2#ixzz6klRowb8S

    Whatever I try I can't get the receiver to display any lights to then pair up with the thermostat.

    I've tried factory reset on the dial, I've tried turning the boiler off at the switch board and then holding down the silver reset button on the receiver for 10 seconds - this does nothing.

    I have also tried to hold the heating button down to reset the receiver.

    Does anyone else have any pearls of wisdom? I have inherited this set up from the previous owners of the property and so don't have any british gas cover

    Thanks again,
    Chris
     
  2. Sponsored Links
  3. picasso

    picasso

    Joined:
    8 Apr 2008
    Messages:
    10,626
    Thanks Received:
    2,665
    Location:
    Essex
    Country:
    United Kingdom
    Pete50 sounds like some sort of expert, let’s wait for his pearls of wisdom.
     
  4. Chris Campbell

    Chris Campbell

    Joined:
    27 Jan 2021
    Messages:
    9
    Thanks Received:
    0
    Country:
    United Kingdom
    Fingers crossed..
     
  5. ianmcd

    ianmcd

    Joined:
    15 Aug 2010
    Messages:
    23,406
    Thanks Received:
    9,650
    Location:
    Lanarkshire
    Country:
    United Kingdom
    But are you removing the batteries in the thermosta then pressing the buttons then putting tha batteries back in at the correct time, like it tells you in the link that you yourself posted
     
  6. Chris Campbell

    Chris Campbell

    Joined:
    27 Jan 2021
    Messages:
    9
    Thanks Received:
    0
    Country:
    United Kingdom
    I have followed the hive instructions here:

    1 Remove the batteries from the thermostat.
    2 Switch off the boiler and receiver.
    3 Wait at least 5 seconds, then turn the boiler and receiver back on. The receiver’s status light will begin to flash AMBER.

    At this stage ^^^ nothing lights up on the receiver

    4 Press and hold the heating button for at least 10 seconds – until the status light begins to flash WHITE. The receiver is now in ‘stand-alone’ mode and is searching for a thermostat.

    ^^^
    The heating button I have on the control is a boost button on the top of the console - holding that in for 10 seconds doesn't do anything, when I release it asks if I want to boost the heating for 1hr


    5 Insert the batteries into the thermostat, press and hold down the menu and back buttons on the thermostat and follow the factory reset instructions on screen. After about 10 seconds, ‘Welcome’ and ‘Searching…’ will be displayed on screen. If the thermostat shows ‘REJOIN’ then try steps 1 and 5 again.

    ^^^ this doesn't occur.


    ----

    I've also tried a few different variations of turning the boiler off and then powering it back up and holding down the reset button on the receiver and that hasn't worked either.
     
  7. picasso

    picasso

    Joined:
    8 Apr 2008
    Messages:
    10,626
    Thanks Received:
    2,665
    Location:
    Essex
    Country:
    United Kingdom
    Please post a pic of the receiver and stat.
     
  8. ianmcd

    ianmcd

    Joined:
    15 Aug 2010
    Messages:
    23,406
    Thanks Received:
    9,650
    Location:
    Lanarkshire
    Country:
    United Kingdom
    what boiler do you have ?
     
  9. Chris Campbell

    Chris Campbell

    Joined:
    27 Jan 2021
    Messages:
    9
    Thanks Received:
    0
    Country:
    United Kingdom
    Updated link for image (sorry not sure how I am supposed to correctly upload)

    https://ibb.co/xgR4vwy[​IMG]


    SOrry I should have done this earlier - does that help @picaso

    The boiler is Ideal Icos HE18 @ianmcd

    Boiler is up and running and working perfectly fine for hot water.
     
  10. Sponsored Links
  11. ianmcd

    ianmcd

    Joined:
    15 Aug 2010
    Messages:
    23,406
    Thanks Received:
    9,650
    Location:
    Lanarkshire
    Country:
    United Kingdom
    are you sure the receiver is getting power ?
     
  12. Chris Campbell

    Chris Campbell

    Joined:
    27 Jan 2021
    Messages:
    9
    Thanks Received:
    0
    Country:
    United Kingdom

    I've checked and it is getting power - please see here

    https://ibb.co/9ZSdVy0

    If it helps, this is the display I have on the thermostat

    https://ibb.co/PwkfX7G

    Thanks,
    Chris
     
  13. JohnD

    JohnD

    Joined:
    15 Nov 2005
    Messages:
    74,182
    Thanks Received:
    4,283
    Location:
    Crossgates, Europe
    Country:
    Cook Islands
    You can put pics into your reply by "copy and paste"
     
  14. ianmcd

    ianmcd

    Joined:
    15 Aug 2010
    Messages:
    23,406
    Thanks Received:
    9,650
    Location:
    Lanarkshire
    Country:
    United Kingdom
    What was the origional problem ? did you just swap the batteries or had it stopped working so you are trying to pair it ?
     
  15. Chris Campbell

    Chris Campbell

    Joined:
    27 Jan 2021
    Messages:
    9
    Thanks Received:
    0
    Country:
    United Kingdom
    HEating stopped a couple of days ago with nothing displaying ob the thermostat so I replaced the batteries and haven't been able to pair since.
     
  16. ianmcd

    ianmcd

    Joined:
    15 Aug 2010
    Messages:
    23,406
    Thanks Received:
    9,650
    Location:
    Lanarkshire
    Country:
    United Kingdom
    Most likely you need to replace both units , nothing wrong with the batteries, the receiver has packed up , lesson learnt dont Hi-Jack or quote other posts as being the same as yours
     
  17. Chris Campbell

    Chris Campbell

    Joined:
    27 Jan 2021
    Messages:
    9
    Thanks Received:
    0
    Country:
    United Kingdom
    thanks Ian
     
  18. DIYnot Local

    DIYnot Local

    Joined:
    3 Sep 2019
    Country:
    United Kingdom

    If you need to find a tradesperson to get your job done, please try our local search below, or if you are doing it yourself you can find suppliers local to you.

    Select the supplier or trade you require, enter your location to begin your search.


    Are you a trade or supplier? You can create your listing free at DIYnot Local

     
Loading...

Share This Page