Danfoss RX1 believed dead?

14 May 2012
Reaction score
United Kingdom
Hi, I wonder if you can help?

I have a Glowworm 30CX combi boiler which is controlled by a Danfoss TP5000 RF room thermostat via a Danfoss RX1 receiver.

I've come home from a weekend away to no heating (hot water on demand is fine), and the boiler is reporting state code S.30 - No heating demand from external controls. The thermostat appears to be working and sending a signal and I've replaced the batteries just in case.

Moving to the RX1, no lights are showing whatsoever. I tried turning off and reinstating power but no lights come on when switched on.

The power to the RX1 comes via a 30mA protector which is not tripped. The power cable going onward to the boiler comes from the RX1, and the boiler has power. I took the box of the RX1 off the wall and all connections behind it appear to make good connections and are tight.

I'm no electrician or indeed plumber, but to me it appears the RX1 is simply not functioning. Is there anything further to test, or is it time to get a new one? (Warranty expired last year of course!)

Sponsored Links
Hi, I wanted to try that but I can get no lights to show on the RX1 at all. The thermostat goes into the mode where it constantly sends a signal and beeps, but there's no response of any kind from the RX1.
Once the stat is sending signal just hold down PROG & CH1 the light should come on on CH1

If it doesn't I think it's new RX1 time I'm afraid they are available seperately
Sponsored Links
Doesn't seem to work.

Am I right in saying that whatever the thermostat is doing, if I press the Channel 1 button the heating should come on? Currently, nothing happens...
If you can't get it to work and you want heating link 2-3 in the RX1. It will over ride the stat so you'll need to turn the boiler off when it's warm enough.
No I think pressing ch1 will just make it "listen to the stat"

Do it alls advice is your best bet to get it working tonite and you should be able to pick a new one up tomorrow and clip on to existing back plate
Thanks very much to both of you. I have bridged the two pins and the house is now warming, just in time for the Mrs to come home!

Will pick up a new one tomorrow and hopefully that will resolve the problem.

Thanks again!
Download the instructions if you don't have them, and also check there's not a fuse blown or loose wire. as well as the batteries are ok.
Hi both, hope one of you can help.

I have come home with the same problem no lights in tge receiver, changed batteries but don't have a clue how to link the two, how would i do it.

very cold and don't get paid until end if next week.



I'm no expert, but having been through the same thing, the instructions at http://heating.danfoss.co.uk/PCMPDF/TP5000Si+RF Easy User Guide.pdf were useful.

I tried pairing the two boxes again, but my RX1 was completely dead. Tried checking the fuse inline to it, but that was fine, hence I replaced the RX1.

To get the heating working temporarily, I followed some instructions above and took the RX1 off the wall (obviously after removing the fuse to it's power source!), and then having made a small insulated linking wire, I linked ports 2 & 3, before reinstalling the RX1. This essentially takes the thermostat out of the circuit, so that the heating will be 'always on', and you can then control it from the boiler.

I found a replacement RX1 on ebay and once installed and paired to the wireless controller it worked perfectly.

Obviously whilst I'm not a heating expert, I'm fairly experienced dealing with wiring etc, if you are not I'd suggest getting some help from somebody who is.

DIYnot Local

Staff member

If you need to find a tradesperson to get your job done, please try our local search below, or if you are doing it yourself you can find suppliers local to you.

Select the supplier or trade you require, enter your location to begin your search.

Are you a trade or supplier? You can create your listing free at DIYnot Local

Sponsored Links