Danfoss TP5000RF and RX1 issue

23 Jun 2006
Reaction score
United Kingdom
Thought it had been getting a bit chilly in the house recently and then today I noticed that the little flame symbol was on on the TP5000RF but the red light wasn't on on the RX1 box mounted next to the boiler.

Pushing the RX1 button turns the heating on showing that the RX1 module has power and its relay is hooked up correctly.

I have now changed the batteries in the TP5000RF and tried the commissioning procedure in the manual but it still doesn't seem to work.

Pushing the PROG and RX1 button on the RX1 box for any amount of time never makes the green light flash like it says it should so I assume the RX1 box is borked.

Anyone got any ideas before I call Danfoss up tomorrow to ask for their help?
Sponsored Links

DIYnot Local

Staff member

If you need to find a tradesperson to get your job done, please try our local search below, or if you are doing it yourself you can find suppliers local to you.

Select the supplier or trade you require, enter your location to begin your search.

Are you a trade or supplier? You can create your listing free at DIYnot Local