1. Visiting from the US? Why not try DIYnot.US instead? Click here to continue to DIYnot.US.
    Dismiss Notice

Fiesta mk4 rear window heater/wiper

Discussion in 'Car Repairs / Maintenance' started by andyj941, 27 Jan 2013.

  1. andyj941

    andyj941

    Joined:
    14 Mar 2008
    Messages:
    171
    Thanks Received:
    0
    Country:
    United Kingdom
    Hi I posted on here a while back about the rear wiper intermittently working and the rear window heater never working on a W reg mk4 1.3 fiesta. Well today I've taken the trim off inside the boot and accessed the earth point - was a bit corroded so cleaned it up with some wire wool and reattached.

    However the bolt holding the earth on can't be tightened properly, it looks like the hole is too big. Is there any way I can get it tight, I don't think I have a nut that would fit on the other side.

    Also there is a loose cable with a bit of tape on the end - this comes from the far right 3 pin connector on the upper boot lid but is not connected to anything - is it meant to be? The colour is purple and blue and I've attached a photo.

    Any advice would be most appreciated!

     
  2. Sponsored Links
  3. Belle427

    Belle427

    Joined:
    16 Jan 2006
    Messages:
    2,964
    Thanks Received:
    284
    Location:
    Newport, S Wales.
    Country:
    United Kingdom
    according to the diagrams the violet and purple cable could go to the heated rear window (one shown on wiper motor too)
    Can you put a new nut and bolt on the earth?
     
  4. andyj941

    andyj941

    Joined:
    14 Mar 2008
    Messages:
    171
    Thanks Received:
    0
    Country:
    United Kingdom
    Thanks for the reply. OK so I have the violet/purple cable that should be for the heated rear window (the wiper has its own both violet/purple and white/orange) but it is only connected at one end to the third or right hand side contact pin - where should the end with the earth tape on connect to? I may have to get some assorted nuts and bolts and see if i can get a bigger one to fit
     
  5. Belle427

    Belle427

    Joined:
    16 Jan 2006
    Messages:
    2,964
    Thanks Received:
    284
    Location:
    Newport, S Wales.
    Country:
    United Kingdom
    i would think it needs to connect to the heated rear window terminal,may be it snapped off thats why someone taped it up?
     
  6. andyj941

    andyj941

    Joined:
    14 Mar 2008
    Messages:
    171
    Thanks Received:
    0
    Country:
    United Kingdom
    Hi does anyone know where the heated rear window terminal is then? It looks like this wire was taped against the wiper motor (assuming that's what the big metal bit is in the photo) but not sure if this is meant to be a proper connection or not.
     
  7. Belle427

    Belle427

    Joined:
    16 Jan 2006
    Messages:
    2,964
    Thanks Received:
    284
    Location:
    Newport, S Wales.
    Country:
    United Kingdom
    i couldnt tell you without looking but the connections are usually at the sides of the screen, can you find the negative connection?
     
  8. andyj941

    andyj941

    Joined:
    14 Mar 2008
    Messages:
    171
    Thanks Received:
    0
    Country:
    United Kingdom
    Hi just realised I haven't sorted this yet. There are two connections on the screen itself, one is where the connection to the wiring is (on the right as you look at it with the boot open) and another on the left where it is joined to the metal bodywork. They both look like a 'bridge' if you know what I mean. Could it be the one on the left that needs disconnecting and cleaning up - it does look a bit corroded.

    As for the wire that was just taped up I'm keen to get the trim back on - do you reckon that it was never used and can just be left disconnected?
     
  9. Sponsored Links
Loading...

Share This Page