Grant Oil Boiler - Pro utility 15/21 Not firing

25 Jul 2006
Reaction score
United Kingdom
Hi All,

We are in our second week of no heating which is not much fun. We have had a few problems with our Grant boiler, basically not firing. There is oil, more detail below, and the motor runs but it won't fire. Building up to this point we had an intermittent fault which resulted in the boiler only firing occasionally, but the motor would not shut down.

I discussed with my plumber and we took a number of actions, see below;

1) solenoid coil spare, replaced last September and again (just in case) two weeks ago
2) New capacitor
3) Fuel line replaced due to existing being loose and different levels along its length - much of the damage was done by previous house occupant with fuel line going through a hedge and consequently it became warped.
4) Tiger loop - to ensure constant oil supply, as my tank is basically level with the boiler.
5) New nozzle due to slight ‘sooting’ x2.
6) Fuel pump due to fluctuating oil pressure and to ensure solenoid operation.
7) New control box.
8) Fire valve replaced to ensure oil supply.

All this has resulted in now in complete non-operation, so we have actually gone backwards. My plumber advised checking with Grant themselves who unfortunately don't offer an engineer service. However they have recommended another local guy, who is coming tomorrow.

Anyone any ideas?

Thanks for any help/opinions.
Sponsored Links
There is relatively little to go wrong with these and it seems that you've already paid to have it pretty much rebuilt! How old is it?

Simple things first. Please tell me he's checked the overheat stat and that it doesn't need resetting.

Thanks for the reply.

This wasnt all done at once, and I have only paid for the fuel line (which needed doing). The plumber is a decent guy and has taken advice along the way. Speaking to both the new and old plumbers they have both said there is little to go wrong and it should be running. I believe he has checked the overheat stat. Can I check it myself, I assume we talking the Overheat thermostat reset button or something else?
Yep. Top right on the front panel of the boiler. It's under a small plastic cap. Unscrew this and just check it hasn't popped out.
Sponsored Links
Just checked it, unscrewed it. There is a white plastic button underneath, it doesn't appear flush so it could be out. I pressed it for good measure but no effect.

And it was installed in March 2012 and has been services annually since.
If it had tripped you would have felt a very positive click when pushed and not a slight spring.

Ok, when the motor runs, how long does it run for and do you experience any lock outs at all?

Can you here the burner attempting to spark?
From your description I don't think there was a 'click' at all, just a push in and out again.

I actually had to hit the lock out button to get it to run then. The motor then runs for 20-30 seconds and the boiler attempts to fire, just after it tries it turns off. Previously it would go into a loop of trying to fire, with the motor staying on, and it would catch about every 1 in 5 times, but right now, nothing. So, I think I can hear the burner attempting fire, but it does not catch.
Well the next basic checks I would be doing is (in order of stupidity as I've done it myself sometimes)

1) check ALL valves are open from the tank Inc fire valves and the sneaky little isolator that is in the boiler bottom left if memory serves.

2) check oil pressure being achieved at pump.

3) check that there is about 50v on the white wire from the burner motor. This sends a signal to the control box.

Oh and just so we are on the same page can you confirm it's a Riello RDB burner and post a couple of pics just so I know I'm thinking of the right boiler lol.

You do not mention a new photocell. I can't believe an experienced would not try that first, but maybe you've forgotten it. When it was firing and trying to stay on but recycling, suggests fuel problems. Maybe it is contaminated or there is a blocked filter. Alternatively it could be overaired. Try covering the air intake with your hand( after removing the air hose if fitted.
The process is fairly simple, and usually following a logical path will identify the faulty part
Was getting to that @oilhead lol. Wanted to try and prove it was actually trying to fire first. I doubt that it actually is and the photocell is holding it off thinking there's a flame before there should be. Was my gut instinct but wanted to try and prove it with some simple stuff first.

Was getting to that @oilhead lol. Wanted to try and prove it was actually trying to fire first. I doubt that it actually is and the photocell is holding it off thinking there's a flame before there should be. Was my gut instinct but wanted to try and prove it with some simple stuff first.

Have you checked for water in the oil?
Thanks for all your replies.

1)Valves open - I will ensure plumber does this tomorrow
2) I saw oil pressure being achieved at pump when tested last week
3) 50v on white wire. Again, I will need plumber to check.
4) And I can confirm it is a Riello RDB burner.

Not sure about photocell, I will need to check.

My current plumber has maintained all along that it is a fuel issue. I believe the tigerloop removes air from the oil. I will need to check with the new plumber tomorrow re air intake. We test the fuel for water and it has come back negative. When they changed the fuel line I think they changed the filter.

Is there anyway to check for contaminated oil?

Yes - negative on water.
Has anyone tried firing up with the burner pulled out from the boiler casing?
John :)

Couldn't possibly suggest doing that on a DIY site but i possibly may have tried it if I were there. Good way to see whats going on and strip the old paint off the skirting boards at the same time :whistle:


DIYnot Local

Staff member

If you need to find a tradesperson to get your job done, please try our local search below, or if you are doing it yourself you can find suppliers local to you.

Select the supplier or trade you require, enter your location to begin your search.

Are you a trade or supplier? You can create your listing free at DIYnot Local

Sponsored Links