Help please - Texecom Veritas Excel Panel Instal

Joined
31 Jan 2020
Messages
2
Reaction score
0
Country
United Kingdom
i apologise if this has been asked before but I've searched threads without success.

I decided to buy a Veritas panel to fit in my sister's home out in Malaysia (the locally available panels don't look as good as the Texecom panels). I brought it out on holiday this week.

It's all wired up using 2 LCD keypads, bell box and detectors. When switched on, a tamper fault is displayed on keypads.

I've looked in the manual at 'trouble shooting' and it refers to removing links but doesn't really further explain which links, if any.

Can anyone advise please? 4 wire cable has been used for the keypads (X 2) and sensors (7 sensors each assigned a zone and wired to their own zone) and 6 wire cable for the bell box.

I've also not yet fitted a battery as I wasn't sure I could take one on the plane, so I'm going to source something locally which suits (12v 2.1ah or thereabouts). Is it ok to use the panel without the battery for now? I assume the battery just provides power if mains is interrupted?

Many thanks in advance for any advice you can offer.

Malaysia
 
Last edited by a moderator:
Joined
30 Oct 2003
Messages
269
Reaction score
23
Location
Worcestershire
Country
United Kingdom
Photo of the panel wiring would be useful
Ideally the battery should be installed before mains but I have run panels on just mains
Is it a panel lid on?
 
Sponsored Links
Joined
20 Jun 2014
Messages
5,767
Reaction score
750
Location
Lancashire
Country
United Kingdom
Look in the engineers manual, you will be able to confirm where the tamper is coming from.

I would put a 7Ah 12V battery which is the max the Veritas can take.

if your still struggling post on what you have done and what it is you cant find
 
Joined
31 Jan 2020
Messages
2
Reaction score
0
Country
United Kingdom
Thanks for replies, I'll look in engineer manual as advised. Thanks for tip regarding a bigger battery.
 
Sponsored Links
Joined
21 Oct 2012
Messages
658
Reaction score
144
Location
Lancashire
Country
United Kingdom
Check the obvious first, make sure lids on keypads, PIR’s and panel are all seated correctly.

You say that you have used 4 core cable for keypads and detectors, have you wired the detectors as EOL or Global tamper (you would need 6 core for Global) assuming the detectors are PIR’s and not just reed switches.

Try a new battery, a faulty battery can cause many different faults.

if using more than 1 keypad you need to connect them before powering up, also they need to have different addresses (dip switches)

Ive installed dozens of Excel panels and they have proved to be very reliable.

As above, a photo may help
 
Last edited:
Top