1. Visiting from the US? Why not try DIYnot.US instead? Click here to continue to DIYnot.US.
    Dismiss Notice

Horstmann economy 7 quartz

Discussion in 'Electrics UK' started by Monika050185, 25 Aug 2016.

  1. Monika050185

    Monika050185

    Joined:
    25 Aug 2016
    Messages:
    10
    Thanks Received:
    0
    Country:
    United Kingdom
    Hi all
    I have recently noticed that the boiler doesn't heat up the water at all (for the past few days) not even with the boost. Off peak light doesn't come on. What might be the problem?
    Will appreciate any advice.
    Many thanks
     
  2. Sponsored Links
  3. Spark123

    Spark123

    Joined:
    2 Jun 2005
    Messages:
    14,841
    Thanks Received:
    474
    Location:
    Cumbria
    Country:
    United Kingdom
    Boiler as in an immersion heater?
    Is the clock ticking around?
     
  4. Monika050185

    Monika050185

    Joined:
    25 Aug 2016
    Messages:
    10
    Thanks Received:
    0
    Country:
    United Kingdom
    Thanks for your reply Spark123. Yes immersion heater and yes it is ticking
     
  5. Taylortwocities

    Taylortwocities

    Joined:
    28 Jul 2006
    Messages:
    19,621
    Thanks Received:
    1,994
    Location:
    Oxfordshire
    Country:
    United Kingdom
    Does the boost work. Does the light come on?
     
  6. EFLImpudence

    EFLImpudence

    Joined:
    7 Jul 2010
    Messages:
    34,002
    Thanks Received:
    3,727
    Location:
    Retired to:
    Country:
    Portugal
    Is the clock showing the right time?

    The clock could be out of sync turning on the off-peak when it is not powered but that still wouldn't explain the boost not working - I don't think - or is it not possible to have the boost on when the off-peak is on even when not powered?

    Does that make sense?
     
  7. Spark123

    Spark123

    Joined:
    2 Jun 2005
    Messages:
    14,841
    Thanks Received:
    474
    Location:
    Cumbria
    Country:
    United Kingdom
  8. Monika050185

    Monika050185

    Joined:
    25 Aug 2016
    Messages:
    10
    Thanks Received:
    0
    Country:
    United Kingdom
    I can still switch on the boost and the boost light will go on but it doesn't heat the water. Maybe the pictures will help.?
     

    Attached Files:

  9. deadshort

    deadshort

    Joined:
    20 Sep 2014
    Messages:
    2,086
    Thanks Received:
    211
    Location:
    uk
    Country:
    United Kingdom
    Have you checked the breakers are all on ?

    DS
     
  10. Sponsored Links
  11. Monika050185

    Monika050185

    Joined:
    25 Aug 2016
    Messages:
    10
    Thanks Received:
    0
    Country:
    United Kingdom
    Double checked, they are all on
     
  12. Spark123

    Spark123

    Joined:
    2 Jun 2005
    Messages:
    14,841
    Thanks Received:
    474
    Location:
    Cumbria
    Country:
    United Kingdom
    The supply must be getting to the switch as the lights work (and the clock is ticking).
    Do you have a multimeter?
     
    Last edited: 25 Aug 2016
  13. Monika050185

    Monika050185

    Joined:
    25 Aug 2016
    Messages:
    10
    Thanks Received:
    0
    Country:
    United Kingdom
    No, unfortunately don't have one :/
     
  14. EFLImpudence

    EFLImpudence

    Joined:
    7 Jul 2010
    Messages:
    34,002
    Thanks Received:
    3,727
    Location:
    Retired to:
    Country:
    Portugal
    The familiar burned neutral - terminal 3 ???

    The lights seem to use a different neutral connection

    upload_2016-8-25_20-31-33.png
     
  15. Spark123

    Spark123

    Joined:
    2 Jun 2005
    Messages:
    14,841
    Thanks Received:
    474
    Location:
    Cumbria
    Country:
    United Kingdom
    The next two steps would be to isolate the supply, disconnect and check the resistances of the immersion heater electrodes to see if they are closed circuit (and check if there is a safety cutout that has tripped). If the safety cutouts haven't tripped, followed by checking if there is a supply to them taking extra care with the electric back on.
    If the cutouts have tripped I'd be looking at the thermostats, more likely the lower off peak one.
    If there's no supply then I'd be looking at the horstmann switch.
     
    Last edited: 25 Aug 2016
  16. Monika050185

    Monika050185

    Joined:
    25 Aug 2016
    Messages:
    10
    Thanks Received:
    0
    Country:
    United Kingdom
    My brother is coming over to have a look at it as I have no idea what I'm doing.
    Thank you all for your help
    Best wishes
     
  17. Spark123

    Spark123

    Joined:
    2 Jun 2005
    Messages:
    14,841
    Thanks Received:
    474
    Location:
    Cumbria
    Country:
    United Kingdom
    Please let us know how your bro gets on
     
Loading...

Share This Page