1. Visiting from the US? Why not try DIYnot.US instead? Click here to continue to DIYnot.US.
    Dismiss Notice

Ideal classic FF240 not firing up

Discussion in 'Plumbing and Central Heating' started by bertiemallards, 30 Oct 2010.

  1. bertiemallards

    bertiemallards

    Joined:
    30 Oct 2010
    Messages:
    11
    Thanks Received:
    0
    Location:
    Northamptonshire
    Country:
    United Kingdom
    Hi All, I'm new to this forum, wondered if anyone can help with suggestions. I have an ideal Classic FF240 boiler, Honeywell C21 programmer. Just yesterday the circuit breaker linked to this tripped, and have now realised that the boiler doesnt fire. i'm pretty good with electrics, have worked out that the glass fuse is ok on the circuit board, though there doesnt appear to be power coming from the programmer even though its display indicates that it should be. For a point of interest i connected a 13amp power lead via a plug to the boiler, the power indicator on the board lit up, the boiler even fired up, but didnt run for long.
    Could this issue be related to the programmer? I'm hoping to try the front panel out on a neighbours tomorrow to see if it works.
    any suggestions?

    thank in advance

    Martin
     
  2. Sponsored Links
  3. weareleeds

    weareleeds

    Joined:
    13 Dec 2005
    Messages:
    664
    Thanks Received:
    2
    Location:
    Yorkshire
    Country:
    United Kingdom
    boiler probably ok only running for a short time because pump not cooling it down have you checked the 3 amp fuse in fused spur (pump may have blown fuse & subsequently tripped rcd)
     
  4. bertiemallards

    bertiemallards

    Joined:
    30 Oct 2010
    Messages:
    11
    Thanks Received:
    0
    Location:
    Northamptonshire
    Country:
    United Kingdom
    Do you mean the spur connected to the programmer if so yes this is ok
     
  5. kevplumb

    kevplumb

    Joined:
    18 May 2004
    Messages:
    23,712
    Thanks Received:
    925
    Location:
    depends where i get sent
    Country:
    United Kingdom
    disconnect the programmer and run a flying lead straight to the boiler

    if it works then its an external control fault :idea:
     
  6. bertiemallards

    bertiemallards

    Joined:
    30 Oct 2010
    Messages:
    11
    Thanks Received:
    0
    Location:
    Northamptonshire
    Country:
    United Kingdom
    Yes thats what i did (see original question) I disconnected the feed from the timer, and connected a straight lead via a 13amp plug, the boilers led lit up and it fired up.
    So does this suggest its the programmer?

    thanks - martin
     
  7. Sponsored Links
  8. kevplumb

    kevplumb

    Joined:
    18 May 2004
    Messages:
    23,712
    Thanks Received:
    925
    Location:
    depends where i get sent
    Country:
    United Kingdom
    does to me

    i would check the pump is free as well :idea:
     
    • Thanks Thanks x 1
  9. bertiemallards

    bertiemallards

    Joined:
    30 Oct 2010
    Messages:
    11
    Thanks Received:
    0
    Location:
    Northamptonshire
    Country:
    United Kingdom
    Is there an easy way to check if the pump is ok, i guess its possible that the programmer is trying to drive the pump, but if its not working that could cause a problem

    pump is a grundfoss 15/50 by the way

    thanks for the input so far

    Martin
     
  10. bertiemallards

    bertiemallards

    Joined:
    30 Oct 2010
    Messages:
    11
    Thanks Received:
    0
    Location:
    Northamptonshire
    Country:
    United Kingdom
    Problem solved

    I disconnected the pump this morning and wired it to a plug, worked fine. Then went to see one of my neighbours, took the programmer front with me, tried it on there identical one, it didnt work, tried theres on my system, everything works fine.

    So it was the programmer that caused the fuse to trip.

    thanks all for your help
     
  11. bertiemallards

    bertiemallards

    Joined:
    30 Oct 2010
    Messages:
    11
    Thanks Received:
    0
    Location:
    Northamptonshire
    Country:
    United Kingdom
    Update on this one..

    New programmer still hasnt resolved this, fuse keeps tripping out on the switch spur for the programmer, any suggestions anyone?
     
  12. bertiemallards

    bertiemallards

    Joined:
    30 Oct 2010
    Messages:
    11
    Thanks Received:
    0
    Location:
    Northamptonshire
    Country:
    United Kingdom
    Have now disconnected the 3 way mid position valve, set it on manual, and system is now working, fuse doesnt blow.
    I think i initially had it set to hot water only, the timer then cut in for the central heating, the timer instructed the valve to move and bang the fuse went.
    So getting a new 3 way valve on order, fingers crossed!
     
  13. DIYnot Local

    DIYnot Local

    Joined:
    3 Sep 2019
    Country:
    United Kingdom

    If you need to find a tradesperson to get your job done, please try our local search below, or if you are doing it yourself you can find suppliers local to you.

    Select the supplier or trade you require, enter your location to begin your search.


    Are you a trade or supplier? You can create your listing free at DIYnot Local

     
Loading...

Share This Page