Megaflo losing hot water pressure

Joined
7 Jan 2018
Messages
1
Reaction score
0
Country
United Kingdom
Wondering if anyone can help. We live in a "new build" house that is c20 years old with a megaflo system as old as the house! In the last year or so it seems to be losing pressure quite a lot

The megaflo is on the middle floor and when I run a shower on the middle floor the hot water pressure is initially quite good for a few minutes then gradually drops to something just about bearable. On the upstairs floor the hot water pressure is ok but not great, downstairs the hot water pressure is fine but I guess that is gravity. Cold water pressure is always fine.

I am aware about the need to "recharge" it (empty it then refill) and I do that roughly every month and it does help for a few days - but no lasting benefit and the problem comes back.

We have lived in house many years and am sure it has not always been like this. I dont know how these things work but there must be a value somewhere that is a bit knackered so wondering if anyone has any idea what it might be, and what the fix is. Trying to work out if its a case of getting it serviced/fixed, or if the whole thing needs replacing (which I would rather not!)
 
Sponsored Links
Joined
28 Oct 2005
Messages
13,547
Reaction score
3,189
Location
Daventry
Country
United Kingdom
They should be serviced annually. Worth getting it checked by a G3 qualified engineer. It might just need a new combination valve
 
Sponsored Links
Top