Miele W562 Washing Machine rinse light flashing

11 Dec 2016
Reaction score
United Kingdom
Hi All
This is a thanks you to all the contributors to the site.
The information I found, while it did not cover my machine (W562) did enable me to have a happy ending.
So I would like to add to the knowledge base with my particular model and issues that I could not find the answer to on the internet here.

My machine had just passed seven years of service when it failed, I did not find miele very helpful apart from wanting to send me one of their engineers. The call out and first hour did not seem that high a price but add another hour or so + part / parts cost and I was heading to over £400 + !!!!

The controller in my machine is a EDPC1000 pn 05413972, it differs from the EL200 one in the thread I found, but my machine exhibited the same display sequences.

Armed with the info from this site and that thread, I bought from E-bay all the parts mentioned, once they all arrived I set about taking it apart to fix the problem.

There were a couple of you tube videos on dismantling miele machines so having viewed them off I went, all was going well until I had to gain access behind the control panel front to remove two hidden screws, the third was accessed by taking out the soap dispenser.
I could find no mention of my model machine nor any reference to the front panel, this caused about a three hour delay as I did not want to damage the fascia.
I made a decision in the end to force the front by getting behind it with two blunt knives, it popped out of the housing, then I could see how I should have gained access.

The trick is to push down from the top of the "panel insert",(SEE FOLLOW ON POST VIDEO IGNOR MY METHOD) the upper edge is held up by two flat springs which push up from the bottom, I suggest two blunt knives about 25% in from each end at the top, try and hook them under the top edge push down and it should pop out!

OK the rest was fairly straight forward and I was able to release the control assembly from the frame (I did not need to take the frame out but was getting nowhere with the previous task!)
So having taken all the plugs out of the PCB and having removed the plastic cover / guard I found I had not got the EL200 controller!!
I should add there was a separate panel with the on/off and door open switches on it which slide out of the plastic PCB carrier frame.

A search on the net brought up a couple of German sites, so I thought oh well I might be sending it off then!
A close look at the EDPC1000 I could see no fuse, there was a fuse but it was a 20mm cartridge type on the on on/off / door open switch panel, it checked out OK!

Turning my attention to the control panel itself it did have several relays on it, I traced out the high current paths that feed the motor and they led to a Omron G2RL-2 12V relay with the same footprint as the relay in the EL200 controller, I am an electronics engineer so I used the helpful trick and powered the relay having checked which pairs of contacts had continuity when no energize voltage was applied, the relay clicked but the same contacts remained connected suggesting the relays contacts had welded themselves together.
Just to be sure I tried with the new relay it confirmed my findings, whey hey!

I replaced the relay with the one mentioned in the EL200 thread, I replaced the drum dampers, I noticed they were not as firm as the new ones.
I had bought the solder in 6.3 A fuse + new brushes so I had all the parts just in case.
I cobbled the machine together just enough to get it to run, it was looking good as the rinse light did not come on and it looked like it was going to work but then!
Rinse light flashing!
OK I thought maybe the controller is looking for the tacho signal, if the motor does not turn then it will show a motor control defect.
I removed the front again, as access to the motor was from the front and sides, the bottom was not removable on my machine.
I took the motor out and using the motor youtube video stripped it down and found one brush almost as new, the other was worn right down!
I cleaned the armature contacts with an ink rubber to get them nice and bright, the brush holders were incorrect for my motor but the brushes and their brass carrier were the same, so I swapped them over.
I reinstalled the motor part assembled the machine again and gave it a run.

So that concludes my story, I will add pictures of the parts I had issue with and hope this will help another person in the future.
The image with the orange relay and pressure sensor shows the replaced faulty relay, I have no idea what its part designation is but that does not matter.
The cutout in the forground is where the on/off and door switch PCB fits when the front is re assembled.

Front Fascia.jpg

Last edited:
Sponsored Links
Nice one! Thanks.
It's easy when you know how :)
I did look long and hard for the info!
This stuff needs to be in one place so anybody taking on the repair has all the facts.

I have read that the MRT37 motor seems to have had earlier failures due to poor manufacture of the armature, I am very disappointed that Miele kept that quite.
I have an old Dyson upright vacuum cleaner, after four years the motor went up in smoke, I called them on their "fixed price repair" the engineer looked at it and said they would replace the motor FOC as there were problems with the early motors!
Shame the "Roll Royce" of washer manufacturers does not have the same attitude towards its customers, still VAG have had a bashing this year as well :)
Last edited:
Can you help me to find PCB on my W582 and how to remove it from there
Thank you,
Kind Regards
Sponsored Links
Firstly anyone with the rinse flashing problem should take a long read of a fabulous example of co-operation on this site. Here's the link


We have a W842 machine with this rinse flashing problem and after reading the above post and searching numerous you tube videos I am now excited as the parts are ordered (see below) and I'm awaiting delivery.




The shock absorbers are not Miele branded (£75) but from the amazon reviews and at £20+ it seems worth the punt.

The only other cause imo could be the bushes.

The 2008 thread is now closed, but if by chance the main "expert" contributors ever read this I just want to say a BIG THANK YOU!!!

ps. I hate to admit it, but I wasted time trying to get the front cover off by assuming it hinged at the bottom (given the info about uncliping it). Lo and behold it opens to the side!! (rht side hinges). Finally got this info from a German you tube clip.

pps don't waste time calling Miele customer services. Health & Saftey barriers firmly erected!
Quick update. Shocks/fuse/relay fitted and reassembled. Switched on and hey presto it now works!!
Miele W3242 here with the same pcb.
It stopped at the end of the washing cycle, and then nothing, no lights on the panel. Dismounted the pcb and found the fuse on the little power and door button board fused. Replaced the fuse and it worked for ten seconds, then lights went off again, just at the start of the drainage procedure. Dismounted the front panel with the door and checked the drainage pump, it got the coil shorted, so got to order a new one from Miele, it was not cheap but not that expensive.
Replaced the pump and the fuse again, plug it in and no lights on the panel, nothing.
Dismount the pcb again, it has to be something with the power supply, check the diode bridge, the oscillator and the power igbt, looks like the last two ate the second short, proceed to order one of each, even the diode bridge. The three are clipped to the heat sink , so you must take it out in order to replace them, just use flux, desoldering braid and a big iron (I use a 80W one), and loots of pacience, be really careful on overheating the board, I did one leg of each every time, so the first one has time to cool down.

Today I replaced the diode bridge, the oscillator (it is a big diode) and the igbt, installed the panel and it worked, we have power and lights.
I started a cleaning cycle and the pump worked at first, to drain the machine, then it took water and when it was going to start the drum, rinse flashing!.

Finally I got to this board, and found this thread, thank you for showing me the way, will order the relay and replace it, I checked the motor and it is fine, brushes are in great shape and they are even, cables look good and continuity tester worked fine with them.
I will update in a few days when I get the new relay.
Hi again, people.
Just received the relay this morning, postal service is slow on summer.
Replaced it and the washing machine is up and running again. Thank you all.

DIYnot Local

Staff member

If you need to find a tradesperson to get your job done, please try our local search below, or if you are doing it yourself you can find suppliers local to you.

Select the supplier or trade you require, enter your location to begin your search.

Are you a trade or supplier? You can create your listing free at DIYnot Local

Sponsored Links