router/modem won't let me see t'internet ?

You have downloaded and ran windsock fix havent you?

Must confess, I hadn't (thought RegEdit would do as it delets temp. internet files etc as well as sorting windows registry).

However I have now, WinSockFix has been downloaded and run - unfortunately it has not made any difference either :!: :?:

I regret, I am still on the USB modem :confused:
Sponsored Links
Winsockfix is not necessary because it appears to be working fine in that respect. Regedit will also do none of things you suggest as it's a registry editor (unless there is another application with the same name).

The issue is with DNS. This resolves names (, etc. into ipaddresses and it's this that isn't working. You've proved that with the pings you have tried. It's likely that there is either no DNS set up or there is an invalid one set manually. From the command prompt, type ipconfig /all and post the full details here.

Also it would be useful to see what DNS settings you have on the wireless connection. Open the Control Panel and double click Network Connections. Right click on your wireless network connection and select Properties. Double click on Internet Protocol (TCP/IP) and ensure the Obtain IP address and DNS automatically radio buttons are checked. Click the Advanced button and then select the DNS tab and post what is on that screen.
You need to be aware that the ADSL modem is working again. I reconnected it to be sure to get the right returns from ipconfig. I don't know what started it working, I just pinged both addresses (209.85..first) to see what happened and also responded.

Windows IP Configuration

Host Name...................Home
Primary Dns Suffix........
IP Routing Enabled........No
WINS Proxy Enabled.....No
DNS Suffix Search List..Belkin

Ethernet adapter Local Area Connection 3

Connection-specific DNS Suffix..Belkin
Description..............................broadcom 440x 10/100 Integrated Controller
Physical address.........00-0B-DB-27-D8-69
Dhcp Enabled.............Yes
Autoconfig Enabled.....Yes
IP Address.................
Subnet Mask...............
Default Gateway.........
DHCP Server..............
DNS Server................

Hope this helps
Submitted via ADSL !
All looks good there. You will need to post the results when it's not working, which we hope won't happen of course ;)
Sponsored Links
Started PC and ADSL modem today but have had to go back to the USB to post this.

Avast updated itself through the ADSL so a connection is definately there but while pinging the usual result, nothing else worked :(

Copied the ipconfig/all settings while the ADSL modem was still plugged in and they are exactly the same as before, though I did miss this one off the list ^^^^ last time: -

Node Type............Unknown

:confused: :?:

I've used this too, to good effect, but it doesn't seem to fit this scenario. It was intermittent before (and now after apparently) and it's affecting two machines at the same time which, whilst possible, would more than likely rule out a winsock issue. These issues affected pre SP2 installations and, although an assumption, I would think the OP is on at least SP2.

Can you look in your router internet/broadband settings (i'll look in the manual if you get stuck to try and help) for the page showing your public ip address and DNS settings (when it's not working) and post them here. You could try a factory reset of the router and set it up again.
Hi all,

Thanks so far for the help. I am going to have to postpone any more fixing, as we are leaving shortly to go to our daughters in Sheffield and won't be back until sometime on the 27th :p

Igorian, I will get the info you have asked for then (I know where to find the set-up page that it is on).

Merry Christmas :)
It is almost certainly your router not picking up the correct DNS server addresses from your ISP (or it has fixed DNS addresses in it which are not valid for your ISP). As I previously suggested, set up fixed DNS addresses in the PC's network adapter. Open up Network Connections, right-click on the Broadcom 10/100, go to Status, then Properties. Click on Internet Protocol and then click the Properties button. Where it says DNS addresses, click the radio button on "use the following addresses" and in the first section type in and the second

If you need to specify a fixed IP address in order to enter fixed DNS addresses, then set the IP address as the subnet mask as and the default gateway as

edit - typo
I agree, Igorian, it is a workaround, but it will (should) get things working while further investigation is carried out. The fact that the OP stated it did (or at least appeared) to work for a short time and then went back to DNS failure implies there is a problem with the settings in the router or the DNS server addresses the ISP is providing by DHCP. IIRC there are some ISPs which require the DNS settings to be entered manually, so herein could lie the problem.
Yup, can't fault that comment re. the ISP. Something we haven't established yet, so Letmedoit, post your ISP when you return.
Hi Guys,

Sorry, got home late on the 27th and also took the missus out last night after work as it was her Birthday (and I am in the good books :D )

So, a little catch up: - using windows XP SP3
Modem settings are: -

VPI / VCI ...................0 / 38
Connection Type ........PPPoE
Encapsulation .............LLC
DNS ..........................Auto
IP Address: ...............Automatically Assigned
Service State .............Enabled
NAT ..........................Enabled
Firewall .....................Enabled
Subnet Mask .............

On a seperate page was: -

DNS.......Automatic from IP

If there is anything missing please let me know

Was talking with son-in law over weekend - who doesn't know much more than me about t'internet (and can't fix cars) and he looked on some websites and said that there were some posts about Belkin software upgrades. Jist of it is my ADSL has version 1.00.17 but while Belkin website says there is 1.00.25-Beta, this should only be downloaded if certain faults are recognised. While the overall problem with my router is not listed, I have noticed that when the router is working I cannot access the Talk-Talk webpage (our ISP and home page) which is one of those faults mentioned.

Do you think I should try this Beta upgrade ?

Sponsored Links