Salus/Altech and Vokera system - no heat

18 Oct 2011
Reaction score
United Kingdom
Hi all. I recently purchased a house and yesterday tried to figure out the heating system. I thought I had but now it doesn't seem to work.

The system is as follows:

- Vokera Compact HE25
- Thermostat - Salus RT500RF (also badged as an Altech014)

Despite the somewhat confusing salus instructions a combination of common sense and more so the threads on this forum I programmed it as follows:

1. 6:00 at 21 (so at 6am it heats the room to 21 degrees)
2. 8:00 at 10 (so at 8am it effectively turns off/comes back on after 8am if room temp. falls below 10 degrees)
3. 18:00 at 21 (as above)
4. 22:30 at 10 (as above)
5. 22:30 at 10 (so it remains effectively off until 6am the next morning).

The good news is that it worked this morning and the radiators heated up nicely. The bad news is that it isn't working now. The thermostat is telling me the room temperature is 17 degrees and there is a flashing symbol (a flame?) so I assume it is calling for heat. A quick trip up to the loft and what appears to be the receiver attached to the boiler I have a green solid LED and a red solid LED. I assume one is power and one is calling for heat.

I have checked the boiler and the water pressure is just above 1 bar. I have a green flashing LED on the boiler at approximately 5 second intervals - looking at the Vokera manual online seems to suggest this is in standby with no faults. Note that I can't hear a noise from the boiler which I may have expected if it was firing and heating the radiators.

So - the thermostat seems to be fine, the boiler seems to be fine, and the system and radiators all worked on this mornings program.

Any ideas?!
Sponsored Links
Sponsored Links
Sorry missed your responses last night but thanks for taking the time to reply.

I had a play around with it and set a new time for 9pm (I set this before 9pm) and then it came on. Maybe it was because when I set it to come on at 6pm this was set after 6pm - can it get that easily confused or could there have been another problem?

Anyway, even though it then came on at 9pm I woke up at 5:00 am this morning and the radiators were still very much on, despite being set to turn off at 10:30pm per the program detailed above. I had a look at the thermostat at 5am and the flashing symbol (which I have assumed is the one that appears when it is calling for hear) wasn't on. The room temp. per the stat was 21 degrees - which is what I wanted just not at 5am!

I can have a look at what motorised valves I have this evening if it still helps (I'm not the most familiar with this kind of stuff so I don't know off the top of my head).

Thanks again, your response is appreciated.

DIYnot Local

Staff member

If you need to find a tradesperson to get your job done, please try our local search below, or if you are doing it yourself you can find suppliers local to you.

Select the supplier or trade you require, enter your location to begin your search.

Are you a trade or supplier? You can create your listing free at DIYnot Local