Smartcom stopped working

24 Jul 2021
Reaction score
United Kingdom
Panel 64w

Smart com V3

The app and notifications have been working very well since I installed the smartcom, about two months ago.

On 3 September the app stopped working.

I got the following error

Keypad - ATS path fault. No ATS available.

Smartcom- wifi led ON. Cloud Server led OFF

App- problem, check internet connection and smart com.

My wifi was working fine and there had been no issues with it. I left the problem on the basis that that the problem would resolve itself. It has not fixed itself.

I have been on the texecom forum and received some advice but it is still not working. Also emailed texecom support but am waiting for a response.

Attempt 1 (note wifi light on at this point)

I have gone to the keypad “enable texecom app” and get the message “Please wait ..............modem is online”.

I have changed com port 1 and 2 back to nothing fitted, then changed to smartcom and comIP Module.

Changed arc 1 to disabled then back to texecom connect.

Still have same problem.

The wifi light on the smartcom is lit solid. I have tried re-establishing the connection by pushing and holding the wifi button but the light stays solid, no flashing light.

Attempt 2

Smartcom cover on. Pushed reset button five times, no change.

Engineer code. Smartcom cover off. Pushed reset button five times, no change

Removed cable from control panel, waited ten seconds and replaced.

Following light sequence

1. No led

2. Then flashing cloud led, 10 steady/long flashes then a short flash (so far so good)

3. Replaced cover and waited

4. And waited, half an hour later and cloud light is still flashing. Manual says “if in doubt be patient”. This thing could try the patience of a saint.

5. Then tried pushing wifi/reset button for 10 seconds, no change. Then tried five quick pushes and hold, no change.

When I first set this up this part caused no problems. Does anyone have any advice on how to reset the smartcom so I can get the flashing wifi light. Any help would be appreciated.
Sponsored Links
okay if your still struggling give us a shout.

the 5 times is the reset procedure?

seems to be long winded but suspect the wifi connection maybe poor. some routers you can see a signal strength indicator for the device. also possible that the wifi channels being used have heavy traffic in the vicinity.

1. check texe_hub can be seen by the router and if wifi what the signal is.
2. if still no joy, remove power from the smart com (unplug and replug in at smart com end)
3. go make a brew and advise on what the leds are up to, should be solid.
Thank you for the response.
Internet connection is good, just checked it. Download speed 148 mbps, Upload speed 29.7 mbps. All that is on the wifi is the smartcom and browsing, no tv, online games etc. No solid walls between router and smartcom. Just checked wifi signal strength next to smartcom and it is good.

1. “check texe_hub can be seen by the router and if wifi what the signal is”. Having problems with finding the descriptions for all the devices connected to the network. I do not think the smartcom is connected to the wifi at present.
2. I have removed power from the smart com (unplug and replug in at smart com end).
3. Had my cup of tea and texecom cloud LED is flashing as before.

One thing I have just noticed is that the smartcom is warm to touch. Not sure where to go next.

Read more:

Read more:
okay so we are assuming that the smart com isn't connecting to the server despite being connected with a good signal over wifi to the router.

Warm doesnt mean much to me to be honest, as its not in any kind of context weather is hot recently rather than warm. the location of the smart com ie new=ar a window or warm wall then its possible it is warm.

The next thing to look at is what does the panel say when you try and generate an app code from the panel.
Then look at the programming in program digi texecom connect and the arc addresses.
Sponsored Links
Thankyou for the reply. When I say “warm” I mean that when I feel the top of the smartcom with the back of my hand it feels warm compared to the bottom of the smartcom and to the adjacent control panel. The smartcom is generating a fair amount of heat at the top. I would not expect this.

I do not think the smartcom is connected to the wifi. Previously the wifi light was on solid when it was working. Since I powered it down and back on the wifi light has gone off and stayed off. I will look further at what is connected to the wifi, problem is that Apple seem to withhold this information so some connected items are not named and I do not know if the smartcom is one of these.
the smart com if connected to your riouter shows the ip address in your routerand if the router shows device names you will see texe_hub.

doing the wifi button 5 is part of the reset procedure, which will wipe out any wfi ssid's and there passwords along with setting the smartcoms password back to that printed inside the unit.

press and hold the wifi button for 5 seconds
connect a device to the smartcoms ssid ARH-xxxxxxxx
usethe password as the pass phrase printed usually in CAPS
in the browser of the wifi connected device type
this should bring up the interface where you select the ssid of your network and enter its password
then exit that screen.

note some devices will advise there is no internet connection when logging into the smartcoms ssid, and to tap for options, you must remain connected to the smart coms ssid until you have set up the unit to connect to the ssid of your network.
Thank you for the input. I have managed to log in to the router, no texe_hub. I have tried the five pushes of the button and do get a response from the smartcom, four flashing lights etc. As yet not managed to reconnect to wifi.

Annoying because when I first set up the system this part (connecting to wifi, getting codes, connecting to texecom cloud) caused me no problem. I will leave it for now, have other jobs to do but later will try five pushes of the button, leaving it then unplugging, leaving it and plugging back in. See if that gets it working.

According to the manual on plugging in it should be no lights, flashing cloud light, no light. Then it is ready for connecting to the wifi by depressing the button and holding for 10 seconds. I am getting the cloud light flashing continuously and the unit gets warm.

As I said before, worked perfectly for 2 months then decided to stop. I am wondering if the smartcom has gone faulty, particularly as it is getting warm.
Keep pressing the button wont do anything to be honest of any value.

Fit these for a living and never one been abnormally warm, especially under normal operation, if its under warranty get it swapped out if your concerned.

I also go back to potential wifi interreference, you can get a wifi analyser app for your smart device and look at 2.4 frequency and all the systems using that channel locally and if they significantly over lap your system, log into the router and change the channel to one that has less potential interreference.

The other option is hard wire it and see of it behaves better, that will at least rule out any wifi issues
Thank you for all the replies.

The yellow/orange plastic box inside the smart com is warm to the touch. I have used a bulb thermometer held against the plastic with multiple layers of tissue paper between my fingers and the thermometer so it gives an indication of the temperature of the plastic rather than the temperature of my fingers. I get the following results

Surface temperature of adjacent control box cover : 24 deg C
Surface temperature of yellow/orange box inside the smartcom : 42 deg C

I sent this off to Texecom and they say the smartcom is faulty so I am exchanging it.


  • 8A663779-F511-4F1E-B3F9-C9B784951CAC.jpeg
    182.2 KB · Views: 79
Never seen one warm to touch, human adult body temp is 36.7oC so 42oC would feel quite warm, but given I got in the car a few days ago and it was 38oC and that felt bloody warm, wasnt a fault with the car, just it sunbathing.

Be interesting to know the cause.
I have now exchanged the smartcom for a new one, very efficiently done by Alert Electrical, I can recommend them. This is the second time they have sorted out a texecom return for me. They use dpd and I was kept fully informed by email, delivered new item and collected old.

The smart com is now working, set up was easy. Top of case is slightly warmer to the touch than the bottom, but nothing like before.

It is a V3 smartcom. LED display during setup is not as given in the instructions. Instructions say cloud light flashes then goes out and then press wifi button. On mine, cloud light continued to flash so I pressed the wifi button and it connected. Instructions do say “an approximate sequence is outlined below” so it is not cast in stone.

I have logged in to the router and found the smartcom, given as texe_hub. If you have a working system it would be a good idea to find out how to find the devices on your router and to find texe_hub. Then if something goes wrong you will know if texe_hub has gone missing. Problem I had when the smartcom stopped working was three devices with just the IP address and no name, I did not know if one of them was the smartcom (None were).

So thank you for all the replies and help.

DIYnot Local

Staff member

If you need to find a tradesperson to get your job done, please try our local search below, or if you are doing it yourself you can find suppliers local to you.

Select the supplier or trade you require, enter your location to begin your search.

Are you a trade or supplier? You can create your listing free at DIYnot Local

Sponsored Links