1. Visiting from the US? Why not try DIYnot.US instead? Click here to continue to DIYnot.US.
    Dismiss Notice

Triton Mixer Shower - No water flow

Discussion in 'Plumbing and Central Heating' started by e111s, 3 Jul 2018.

  1. e111s

    e111s

    Joined:
    3 Jul 2018
    Messages:
    1
    Thanks Received:
    0
    Country:
    United Kingdom
    Morning all, I've tried to find a similar post but couldn't find an answer anywhere so apologies if this is a repeated/common post but I do need some help.

    I have a Triton Mixer Shower upstairs (not 100% sure on model but looks similar diagram to Triton Antares) that I cannot get to work. It has always worked spot on for us but around a couple of months ago I noticed a delay in turning the shower on and the pump kicking in and it got progressively worse to the point that I couldn't get any powerful flow (just dribbles). I've replaced the pump for a new one and found that the problem still exists (Waste of £200!). I've been able to get the shower to work by rotating the temperature valve until the pump kicks in however even this little trick doesn't work anymore, I now cannot get any flow from the pump no matter how long I leave it or play around with the temperature...

    Me and my dad had a look and we believe it could be the thermostatic cartridge blocking the cold water therefore not sensing good flow to activate the pump (hence constantly having to adjust temperature valve to get pump to work). This is the one I am looking at...https://www.showerspares.com/search/triton_thermostatic_cartridge_83307340/
    As this part is quite costly I just wanted to get some second opinions before I rush and buy one and waste more money like the new pump, thank you so much for any help guys :D
     
  2. seco services

    seco services

    Joined:
    3 Dec 2007
    Messages:
    15,697
    Thanks Received:
    1,259
    Location:
    Essex
    Country:
    United Kingdom
    you tried cleaning the shower non return valve/filters ?
     
  3. DIYnot Local

    DIYnot Local

    Joined:
    3 Sep 2019
    Country:
    United Kingdom

    If you need to find a tradesperson to get your job done, please try our local search below, or if you are doing it yourself you can find suppliers local to you.

    Select the supplier or trade you require, enter your location to begin your search.


    Are you a trade or supplier? You can create your listing free at DIYnot Local

     
Loading...

Share This Page