1. Visiting from the US? Why not try DIYnot.US instead? Click here to continue to DIYnot.US.
    Dismiss Notice

Vaillant ecotec pro 28 and wifi stat issue

Discussion in 'Plumbing and Central Heating' started by oldspark, 21 Jul 2021.

  1. oldspark

    oldspark

    Joined:
    22 Dec 2004
    Messages:
    87
    Thanks Received:
    1
    Country:
    United Kingdom
    moving to a new house and am taking my salus wireless thermostat with me. the plumber quoted me for the new house install and included an EPH CP4 RF thermostat so I decided to remove the salus500 and fit the new one before leaving. connected everything up but the thermostat is not switching the boiler off and on when i power up the central heating comes on and stays on.
    the back box wiring seems to be the same for both units and i connected the cables the same as the one i removed
    seems simple enough
    mains in and looped out to the boiler
    link between live mains and terminal 2 on the unit
    and a grey one on terminal 1 on the EPH to the RT block in the boiler
    Any idea what i am doing wrong
    photo attached
    PS on the Salus the grey is from the NO terminal to the boiler
    Thanks
     

    Attached Files:

  2. Sponsored Links
  3. CBW

    CBW

    Joined:
    26 Sep 2019
    Messages:
    7,793
    Thanks Received:
    2,010
    Location:
    North
    Country:
    United Kingdom
    Try putting the grey wire where it should be, in NO (terminal 3).
     
    • Thanks Thanks x 2
  4. oldspark

    oldspark

    Joined:
    22 Dec 2004
    Messages:
    87
    Thanks Received:
    1
    Country:
    United Kingdom
    Chris your dead right, works a treat
    Thanks
     
    • Thanks Thanks x 1
Loading...

Share This Page