Wireless Network Probs...

1 Nov 2006
Reaction score
United Kingdom
I have recently set up a home wireless network using a Philips wireless modem/router.
Main PC is connected via LAN cable and Wireless Adaptor.
Second PC is connected via wireless only.

I'm having a couple of probs.
1) Second PC will not connect to Wireless Router unless main PC is switched on (doesn't have to be logged on).
2) main PC will not connect to net unless wireless adaptor is used, I can't seem to get it to use the LAN connection through the router to get online.

Is it me?

What settings would I need to change so that the second PC could "wake" the router without needing main PC to be on.

How do I configure my PC to connect to t'internet using the wired LAN?
Sponsored Links
Sounds a bit of a mess :).

OK - could be a lot of things but this is first thoughts.

If the second is dependent upon the first - then I suggest you might have internet sharing turned on on this machine. Whatever, I recommend starting again from scratch rather than fiddling about.

Also, having two links from the first to the router is not a great idea as there can be routing issues and confusion as to how it's configured. I would go with the cable and disable the wireless as cable is easier to trouble shoot.

These instructions assume the router is running as a DHCP server - most do. If you're unsure of this, follow the instructions below and we'll troubleshoot that isssue if it doesn't work. If you know you disabled DHCP server on the router - let me know.

OK. assuming you've got XP. Do this to main PC:

Start - control panel: switch to classic view.
Double click network connections:

There will be two icons for the local LAN and for the wireless connection.
for the LAN, right click and pick properties. Scroll down to TCPIP and click properties. Make sure 'obtain automatically' is selected for all general options. Next, go tot the advanced tab and make sure 'allow other network users....' is unticked. (You want the other to go through the router - not the PC).

Then OK out of it back to the network connections view. Now right click on the wireless adaptor icon and select disable. This will turn that network off.

Now - on the second PC - configure the wireless network interface exactly the same as you did for the cabled LAN connection on the main PC.

OK. Now both are set up as TCPIP clients looking for a DHCP server to assign network addresses to them. This is the role of the wireless router and most routers are configured to do this out of the box. If this is the case, both PCs should now be able to browse the internet.

If you want to share drives, printers, that's a bit more work.
Forgot to add, I can get the second PC to connect without the first being on, as long as I turn the router on at the same time.

The problem arises if both PC's have been off for a while and the router has gone to sleep so to speak...

I'll try getting rid of the wireless adaptor from main PC, but last time I did that I couldn't connect to net, and couldn't access the router config through IE.
Sponsored Links