Eurosec CPX Keypad

12 Aug 2019
Reaction score
United Kingdom
I've moved into a new house with a Eurosec CPX system installed and I triggered a tamper alarm by knocking one of the PIR's.

The keypad during alarm state says "!!ENTER CODE!! !!!!CHECK!!!!"
However entering codes (or anything for that matter) at the keypad has no effect. The buttons beep but its as if no data transfer is happening back to the panel.

I've powered down the panel and on restart the keypad is illuminated and showing the date and time. Its still unresponsive to any input. The buttons are beeping but nothing happens.

I've used the previous owners code, default engineers codes and the installers engineer code. I've tried yes no system resets but nothing is registering.

The alarm panel now triggers randomly. I can't set or unset the alarm so have to pull the fuse and let the SAB time out (not the best intro to our neighbours!)

Is there any way to test if I have a faulty keypad before buying a replacement? Alternatively anyone know of anything else I can test?
Many thanks
Sponsored Links
It does. I forget the date is but the time starts from midnight 00:00:00
Have you ever actually used the alarm ....with the code provided ? It may be programmed for master reset only , and the code they have given you is a user only code ...or eng reset only on tamper !
Sponsored Links
Thanks sparkymarka,
No I never used the code so it could be a dud.

The callout charge is going to be £96 plus parts. I’m wondering if returning to the factory for reset is an option or just buying a new panel and fitting myself.

The CPX seems to be a good piece of kit but been around for a while. Would you know if there better options these days?

Thanks again for the response
Pretty confident. It has the wireless module added on it and the vocomm connection to the phone line.
The original installers also confirmed it was a CPX.
I’ll double check though. could try a code only default on it as you haven’t anything to lose ....worst case it’s eng locked , but you will have a master code
No joy sadly. Also contacted Risco who will only deal with trade.

I took the keypad off the wall earlier while the system was powered up and it didn't trigger a tamper alert.
I'm going to do a continuity test on the data line tomorrow. Although you guys might tell me if it switches to the error message in the pic above that the data line is fine.

I think I'll start unwiring the panel and disconnecting externals to see if anything changes. I have a feeling I'm destined for a new panel.
I know this is an old thread, but I'm having the same problem, and would love to know whether you fixed it. In my case everything worked for a while, until it didn't.

DIYnot Local

Staff member

If you need to find a tradesperson to get your job done, please try our local search below, or if you are doing it yourself you can find suppliers local to you.

Select the supplier or trade you require, enter your location to begin your search.

Are you a trade or supplier? You can create your listing free at DIYnot Local

Sponsored Links