Whirlpool ADG 7470/2 dishwasher shows fault: 6 flashes

Discussion in 'Appliances' started by k-doge, 12 Jul 2021.

  1. k-doge

    k-doge

    Joined:
    12 Jul 2021
    Messages:
    1
    Thanks Received:
    0
    Country:
    United Kingdom
    Hi Everyone!

    I have a rather old integrated dishwasher, Whirlpool ADG 7470/2. As of recently it refuses to work, showing "6 flashes" error code. Perhaps local experts could help me figure out what is going on. Here is what I know so far:

    (1) "6 flashes" apparently means that the dishwasher does not sense that water is being filled in.
    I, naturally, checked for the obvious silly problems, like a closed tap or a kink in the hose -- everything is fine.
    (2) Hence, the problem is either with the flow meter, or water indicator. Right?
    (3) I took the dishwasher out, removed the left panel and examined the AK22-A assembly (dosage regulator thingy), and removed and examined the flow meter reed switch. It seems intact, passes basic electric tests (open circuit normally, contacts are conducting); I cleaned the contacts just in case -- still no luck.
    (4) The water does fill in -- I ran the machine with the door open (but inserted the plastic latch part so it thinks the door is closed) -- water enters just fine.
    (5) Out of curiosity I ran the machine with the flow meter completely disconnected. INTERESTING: In this case the error code is slightly different: not only the X led flashed, but the Play led also flashes (continuously) and it keeps beeping. (With the flow meter connected it just flashes the X led 6 times).
    (6) This leads me to think that the problem might be with the water indicator.
    However, I cannot even find where it might be located nor can I find any service manual for this model.

    At this point I do not know what to think.
    Any thought? Thank you!
     
  2. Sponsored Links
  3. Jezwillmar

    Jezwillmar

    Joined:
    14 Dec 2012
    Messages:
    2
    Thanks Received:
    0
    Location:
    Lincolnshire
    Country:
    United Kingdom
    Hi I have the same issue. 6 flashes cancels the program. Water getting in. Cleaned filters etc. Did you fix this?
     
Loading...

Share This Page