Galaxy Flex programming assistance

25 Sep 2016
Reaction score
United Kingdom
I've got a galaxy flex (firmware 3.37) that works flawlessly bar issues setting night mode from the panel.

One of the issues I have is that a zone that needs to be set when the house is empty otherwise needs to be open during night mode.

I can set night mode from the iOS app no issues.

On the panel I have an option of setting:

TIMED SET (works fine when house empty)
INSTANT SET (works as expected but can't use for night mode due to open zone requirement)
SILENT PART (only works if exit zone opened and then closed)
HOME SET (fails on open zone requirement, and won't set unless exit zone opened and closed)
PART SET this then gives the option of part set (won't arm until exit zone opened and closed) or night set, which works as expected.

Is it not possible to program the keyboard to enable night mode simply by pressing the A or B key without having to go through various menu options first?
Sponsored Links
thanks, but there is no option for final door set on the flex. The timed set option is designed to set once the final exit door is opened and closed, which is fine when the alarm is being set when the house is empty. I want a way to be able to do a night set, when the house is occupied, to arm some zones by simply entering a user code and then one of the A or B keys. Is that not possible?
You mean firmware 3.17 ?

You need to change the night set exit timer 51.4.2 to greater than 0. You then enter your code and press B 2 (ent) for night set. If you want to use part set, then you need to increase the regular exit timer 51.4 to a vaule greater than 0. When set to 0, the part set timer requires the final zone to open and close to set the system.

You can also program the A and B keys to perform full set for key A (without the need to enter the code prior) to set and night set for key B (also without the need to enter the code prior). This is not something you should do if children have access to the keypad, as they can inadvertently set the system with a single key press. (menu options in 58.1.1/2.1/2)
Sponsored Links
Perfect, I had overlooked the default value of the exit timer being 0. I was aware of the ability to program the keys without entering a code and wondered what downsides there might be. Typical, children!

And I mean 3.37, assuming the value from Menu 23.
One final thing, I've obviously changed something but I cannot remember what. When I unset the alarm (code + ent) i'm sure it always used to just unset the alarm. Now as well as unsetting the alarm I get a menu pop up after pressing enter - '0=OMIT ZONES [ent] to Select' and now have to press ESC to get back to the default display. Any clues what's causing that?
It sounds like you've changed a few settings when trying to understand the system. Time to load defaults and start again. Or, if you have RSS, you can compare all your changes with rollback.
Possibly, but that's not the reason here. I've tried both rolling back and resetting to default. When unsetting the alarm, you always get prompted with a menu after clearing any alarms, if any. Perhaps I was imagining it just unsetting the alarm, or maybe it was the default on a previous honeywell system at my old house.

Anyway, another question. For some reason, alerts aren't being sent to the ARC (aka selfmon) if an alarm is tripped during night mode. I guess that makes sense given there is always someone in the house, but it would still be useful to get a notification on which zone triggered the alert before going to reset the system.
I'll need to have a play around to see what's causing the menu issue. I'm assuming that from default, you have no zones opted for omission ?

As per the SelfMon panel setting menu in 'Panel Settings' for the Flex. Ensure that you have enabled for alarm transmissions in part set:

51.11 - LOCAL PART (You may want to ensure that Local Part is ENABLED to allow events to be sent when in part set mode)
I now have a test panel at 3.37 and see that unsetting with code 'ent' now enters the menu system. That's a pain in the butt and surely a bug that's been introduced - but may be a new feature :(

You can unset with Code then A as a workaround.

Also, you asked about quick set previously. You can achieve this by setting the A and B buttons functions in menus and to (No Code). This will set the system without the code. You may also want to set to 17 to set silent at night.

DIYnot Local

Staff member

If you need to find a tradesperson to get your job done, please try our local search below, or if you are doing it yourself you can find suppliers local to you.

Select the supplier or trade you require, enter your location to begin your search.

Are you a trade or supplier? You can create your listing free at DIYnot Local

Sponsored Links