Optima Compact G3 Tamper Lock

17 Oct 2022
Reaction score
United Kingdom
I have an Optima Compact G3. It was in the house already when we moved in back in 2006. It has worked fine, had to replace the battery about 10 years ago and it worked fine afterwards.

A couple of months ago the tamper light came on and then none of the buttons on the keypad work. I suspected that it might be the battery again so have replaced it (only just got round to it) with a new one. The old battery was indeed faulty when I tested it with a volt meter. The new battery is reading 12v fine.

However, it has not fixed the issue, the tamper light is still on and the keypad is not responsive. Looking at the manual it describes this as a lock out, but it does not offer much in the way of help to fix it.

Any advice? - is there some sort of reset I can try? I have been round to all the sensors and they all respond with movement as normal. The tamper spring sensor does not seem to make any difference if I push on it or not (when the cover is off).

Sponsored Links
Link out/ short out the following …..global tamper, keypad tamper, bell tamper return ….does it clear ? Ok it does , now remove one shorting link at a time , till you find what was causing the tamper , then look further at the issue….
Short out as per picture , leaving the existing wiring in ….


  • 6900D810-3F13-4927-A28E-631F9C12334C.jpeg
    208.1 KB · Views: 27

DIYnot Local

Staff member

If you need to find a tradesperson to get your job done, please try our local search below, or if you are doing it yourself you can find suppliers local to you.

Select the supplier or trade you require, enter your location to begin your search.

Are you a trade or supplier? You can create your listing free at DIYnot Local

Sponsored Links