Texecom premier elite wireless sounders

Joined
11 Oct 2009
Messages
114
Reaction score
0
Location
Bristol
Country
United Kingdom
Just wondering if anyone else has experienced same issue.

I fitted a premier elite wireless system just over 3 years ago. After about a year I had a battery fault on the internal sounder. Took the 8 lithium batteries out and tested them 7 were at 1.7v or above, one was 0.1v.

Now after just over the 3 years i was getting repeated tamper alarms on external sounder. So assuming it was probably a battery fault (since Texecom claim 2-3 years life on a set of batteries) have replaced them and exactly the same thing has happened. 7 are at 1.7v or above and one is completely shot.

So just wondering if this is a common problem and also would you save the Lithium AA's for future use or is it likely that they are all near end of life?
 
Sponsored Links
Joined
16 Feb 2011
Messages
9,345
Reaction score
1,446
Location
Sheffield
Country
United Kingdom
Sure is .... I would keep them as spares had a couple of units with the same issue ...don’t fit Texecom wireless parts anymore ( still fitting hardwired )
 

DIYnot Local

Staff member

If you need to find a tradesperson to get your job done, please try our local search below, or if you are doing it yourself you can find suppliers local to you.

Select the supplier or trade you require, enter your location to begin your search.


Are you a trade or supplier? You can create your listing free at DIYnot Local

 
Sponsored Links
Top