2 stroke issues

Joined
22 Jan 2007
Messages
8,326
Reaction score
4,168
Country
United Kingdom
Hey all, have a titan 2 stroke multi tool hedge/chain saw/brush cutter tool from screwfix a few years ago.

Lines and purge bulbe were worn away and leaking so replaced them.

On using the bulb the fuel runs through the carb fine, starts no problem, and will idle away no issue.

On throttling it it revs up and dies. Will keep doing same every time. Use the bulbs to.move some fuel through it, and it will rev up fine for 15 sec or so then die again.

Have checked and ran with air and fuel filter removed same issue. New fuel, mix checked, lines purged all good, but problem remains.

Which I guess only leaves an issue with the carb? It's like it's not drawing fuel up through the line fast enough on full throttle.

How does a 2 stroke draw fuel in? Anything else I should try before giving up?
 
Sponsored Links
I’d say you have a partial blockage in either the main jet or float chamber needle valve. Sometimes they have a very tiny gauze filter on the fuel inlet.
 
It's that something you normally can get to without disturbing the gaskets usually? Got a few pics of the carb I'll put up later
 
Sponsored Links
20200419_151156.jpg
20200419_151148.jpg
20200419_150636.jpg
 
It looks very much like a Walbro WYK 186 carb.
Anyway, it will have to come apart for a clean. See the two black lines? They consist of a gasket and diaphragm and when you undo the 4 screws on the bottom to split the carb they may, or may not split :eek:
Can I direct you to GHS Ltd, and look under the carburettor section......there in the chinese carb section should be either a new carb (part number 7257) or a replacement gasket/diaphragm set.
You’ll also need an aerosol can of carb cleaner to flush it through.
John :)
 
Hey all, have a titan 2 stroke multi tool hedge/chain saw/brush cutter tool from screwfix a few years ago.

Lines and purge bulbe were worn away and leaking so replaced them.

On using the bulb the fuel runs through the carb fine, starts no problem, and will idle away no issue.

On throttling it it revs up and dies. Will keep doing same every time. Use the bulbs to.move some fuel through it, and it will rev up fine for 15 sec or so then die again.

Have checked and ran with air and fuel filter removed same issue. New fuel, mix checked, lines purged all good, but problem remains.

Which I guess only leaves an issue with the carb? It's like it's not drawing fuel up through the line fast enough on full throttle.

How does a 2 stroke draw fuel in? Anything else I should try before giving up?
When I had the same problem I increased the oil mix slightly which cured the problem , ok when idling but needed more oil at higher Revs.
 
Hey all, have a titan 2 stroke multi tool hedge/chain saw/brush cutter tool from screwfix a few years ago.

Lines and purge bulbe were worn away and leaking so replaced them.

On using the bulb the fuel runs through the carb fine, starts no problem, and will idle away no issue.

On throttling it it revs up and dies. Will keep doing same every time. Use the bulbs to.move some fuel through it, and it will rev up fine for 15 sec or so then die again.

Have checked and ran with air and fuel filter removed same issue. New fuel, mix checked, lines purged all good, but problem remains.

Which I guess only leaves an issue with the carb? It's like it's not drawing fuel up through the line fast enough on full throttle.


Take off exhaust and see if ther is a gauze filter blocked.
 

DIYnot Local

Staff member

If you need to find a tradesperson to get your job done, please try our local search below, or if you are doing it yourself you can find suppliers local to you.

Select the supplier or trade you require, enter your location to begin your search.


Are you a trade or supplier? You can create your listing free at DIYnot Local

 
Sponsored Links
Back
Top