Texacom veritas R8 panic button fault

20 Apr 2015
Reaction score
United Kingdom
So an after-school 'incident' occurred and the upshot is the panic button was hanging of the wall..

No issue I think as the wires still in place so its obvious the location of each. Anyway I've remounted the button and re-seated each wire in their original terminals.

The issue now being that when I set the alarm (full or part) the zone 8 light flashes and it beeps 8 times (over and over) (Z8 is where the panic button is attached). I can omit z8 and set the alarm fine (tested it by tripping a PIR - sorry neighbours)

My first though is a cable fault, but the panic button when pressed does trigger the alarm..? (It's a Honeywell button BTW)

I assume the reed is normal open and the magnet closes the circuit when the front panel is attached, then when the button is pressed the magnet is lowered and the circuit opened and alarm triggered (or do I have this backwards?).

I metered across the reed terminals and there is no continuity when the front panel is not attached, on removing the probes the alarm is triggered.

So my first thought of a cable fault now seems incorrect?? Electronics are my thing, but I'm a novice when it comes to alarms. Had a look through the installer manual and it confirms a sensor fault being the likely cause, but Im not sure where the fault is?

Is it possible the plastic mechanism is faulty in some way? it 'appears' in-tact and functioning.

Any pointers would be really appreciated.

P.S. In a (probably) unrelated side note (not the main issue) I noticed when removing the front panel of the PA that the tamper pair appear to be just attached directly to each other in a spare terminal in the PA switch and not attached to the tamper switch at all - is it normal to bypass a tamper like this? Seems odd to me. I did separate them and as expected the tamper alarm gets triggered - I believe the tamper is a loop and as such this bypass causes no direct issue but obviously the tamper fails to function.
Sponsored Links
Firstly the panic button if on zone 8 isnt programmed as panic as it should be sounded set or unset.

pictures of wiring ,any help here, panel zone 8 and pa button
Thanks the reply, sorry if I misunderstand but to clarify the panic sounds when pressed regardless if the alarm is set or not.

Can't get a pic just now (away from home) but the wiring is very simple: 1 pair connected to the reed and another pair connected together(tamper) these head back to the main board and 1 pair into z8 and the other pair joins the tamper loop.

Issue also is I don't have the engineers code so have limited access to program the zone.

But the main thing is the button has worked fine in the past but now display a fault, can't help but feel it's a mechanical issue with the actual switch.

Thanks again.
If the panic button triggers when you press the button and only when you press the button then the panic button is working correctly.

However panic buttons are supposed to be a 24 hr zone, if its active it should be on all the time until the panic button and the panel are reset.

If zone 8 is active when you are trying to set the system then the unit is not reset or a wire is not correctly fixed it is that simple.

The chances are the reed is broken, in which case correctly wired or seated will make no difference, so you can manually close the circuit to test.
manually with a magnet to open and close the reed, and or bypass it with a short piece of wire.

Without pictures its hard to say if the unit appears to be correctly wired or seated.
Sponsored Links
Again thank you so much, that does clarify the matter.

So if the circuit is normally closed I will connect the pair and test the system again.
I did consider the reed or the plastic (with the magnet) being faulty so I will investigate that also.

Either way gives me something to go on!

Thanks again for your help.
Good news is it's now sorted out. TLDR version; faulty device.

Long version:
The key piece of info was that the circuit is normally closed.

So I removed the button from the wall, removed the front panel and closed the circuit manually (by joining the pair) error disappears from the panel and the alarm now sets correctly - so wiring appears ok.

I completely remove the button from the alarm wiring and put the meter across the reed and it's open, good so far, then closed it using a magnet, closed! All correct. (Confusion sets in at this point)

I decided then to attach a couple of jumpers to the reed and screw the front plate back on - this is when it gets interesting. The circuit is not closed with the front panel on! Pressing the button down then briefly closes then opens the circuit..
So I give the button box a little squeeze and circuit closes! (Pushes the magnet closer I guess)

I remove the front panel and lift the reed slightly, test again and all is fine!

Anyway, for now it is working and a replacement is in the post and will be installed tomorrow if it arrives!

Thanks so much to secureiam for confirming the correct operation, that was the clincher.

DIYnot Local

Staff member

If you need to find a tradesperson to get your job done, please try our local search below, or if you are doing it yourself you can find suppliers local to you.

Select the supplier or trade you require, enter your location to begin your search.

Are you a trade or supplier? You can create your listing free at DIYnot Local